FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

cRIO Flashing Error


Our team is attempting to flash a new firmware on the 8-Slot cRio with the windriver setting. When flashing the cRio imager software hangs at the reboot of the cRio. When it hangs, the status light blinks twice every two seconds. When power cycled the cRio continues this two blinking pattern. Any suggestions?

0 Kudos
Message 1 of 11

The reboot of the cRIO occurs when the IP gets changed.

Often a directly connected laptop will lose connection with the cRIO during the IP change, because it can't handle the IP quick change.

The common solution is to interpose a router or switch that will maintain the connection for you during the change. Those devices are better suited to changing IP addresses.

The two yellow blinks means there is no image/OS on the cRIO, and that's because the image gets downloaded after the IP change. Since your laptop lost connection during the IP change, it never got an opportunity to download the cRIO image.

0 Kudos
Message 2 of 11

When our cRio hung during reboot, we flipped the safe mode DIP switch on the front of the cRIO and rebooted and it worked fine.

0 Kudos
Message 3 of 11

Switching to a router or switch as Mark suggested is a great first step. You can also try putting the cRIO into Safe Mode as noted by albfrc.

If you still have an issue, you might want to try checking your network settings (IP address, subnet mask) to make sure they are properly configured. The Driver Station software will automatically set your IP address if you enter your team number. But you can also manually set your computer's IP address if needed. This is described in the FRC Getting Started Guide, page 16.

Also, make sure you do not have a Gateway or DNS Server defined on the cRIO or host PC (these should be blank or

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 4 of 11

Though I will next try tomorrow, I can try to give additional information. I think it may be the fact that my computer uses predefined DNS servers. I will attept to turn these off on my next attempt.

In addition, I will go into more detail on how the imaging software behaved:

I can find the cRIO, and can successfully connect to it.(I opened up ftp with cmd and successfully connected to the IP address.)

When attempting to reformat the cRIO with the supplied .zip file, the software successfully reads the DIP switches, then appears to successfully transfer the OS file to the cRIO. The program then hangs when trying to reboot the cRIO over the network. During this time the cRIO flashes 2x. I had once tried to do a manual power cycle. This action did nothing.
The cRIO is connected over the supplied Ethernet brige. My windows 7 laptop is connected to the brige with a standard Ethernet cable.

My laptop is using the correct IP address when updating the OS of the cRIO.

I will attempt to remove my DNS servers, but I have a feeling this will not do anything consitering the fact that it is a direct IP connection, thus the DNS servers should not be contacted at all.

EDIT: Should I try manually sending the .zip over FTP?

0 Kudos
Message 5 of 11

You can also try manually putting the cRIO into safe mode before reimaging. With a cRIO-FRC I (8 slot), you can turn on the Safe Mode dip switch and restart the controller. For the cRIO-FRC II (4 slot), you can do this by holding the reset button for 5 seconds. The Status light should blink 3 times to indicate safe mode.

It's also a good idea to check your Windows Firewall and antivirus settings to make sure they aren't causing communication issues.

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 6 of 11

Thank you for all of the suggestions, but I have not been able to continue. The program still hangs when trying to reboot.To reiterate I have:

  • Made sure my computers IP and Default gateway connections are correct
  • Put the cRIO in both safe and regular mode
  • Tried with both direct connection(Straight from my computers ethernet port to the cRIO's 1st port) and throught the supplied ethernet switch
  • Disabled Windows Firewall and my AVG anti-virus
  • I have no DNS server defined on my computer. I cannot connect to the cRIO to see if it has a DNS server defined
  • Pinging the given IP from the reimaging program results in a "PING:transmit failed. General Failure
  • Pinging the IP of what the cRIO is supposed to be results in a ping timeout

I have also tried reading the built in serial console, but the usb converter status lights tell me nothing is being transmitted.

I'm really stumped on this one. Any help at this point would be very very greatly appriciated.

0 Kudos
Message 7 of 11

To enable the Serial output, you need to turn on the Console Out dip switch and restart the controller. This is the cRIO-FRC I with dip switches, correct? (See the procedure for 4 slot cRIOs below.)

To clarify, do you have anything but defined as your computer's gateway? For direct connection and switch this should be the case.

Have you tried finding the cRIO in Measurement & Automation Explorer (MAX)? This might help us troubleshoot the connections issue. For more help with this, you can call NI FRC support at 866-511-6285 between 1-7 PM Central M-F.

(On a four-slot, Safe Mode can be reached by holding down the Reset button for 5 seconds, releasing it, and holding the button down for 5 more seconds. This process puts the cRIO-FRC II into Safe Mode with an IP Reset and Console Out turned on.)

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 8 of 11

This is the first edition cRIO. I had turned on the console out dip and power cycled the controller. The computers gateway shows no numbers.

I successfully connected over MAX. Here are some important system parameters:

System Settings:

IP Address:

System State: Inconsistent IP Settings

Network Settings:

Configure IPv4 Address: Static

IPv4 Address:

Subnet Mask:


DNS Server:

Throught MAX I have been able to connect, and set parameters like IP addresses. Terrific progress! Any details on Inconsitent IP Settings?

0 Kudos
Message 9 of 11

It sounds like the network settings are not saving properly. This happens when the host PC is statically set and the cRIO is using a link-local address (169.254.x.x).

Try changing your computer's IP address to match the current cRIO subnet (something like and then save the Network Settings. Once they apply correctly, you can move your host computer back to the correct IP address.

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 10 of 11