FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Unable to re-image roboRio

We are a rookie team to FRC - team 6364, and we are having issues with re-imaging the roboRIO. At first we imaged the roboRIO and it worked fine and we had installed the correct version of Java on it. However, today when we tried to upload some new code the following error occurred:

roboRIO not found, please check that the roboRIO is connected, imaged and that the team number is set properly in Eclipse

Note that this error did not showed up the previous times we tried uploading the code (it upload fine). This prompted us to try and re-image the roboRio using the FRC re-imaging tool, however it gave the following error:

We could not load the roboRio IP in the browser (

Also, we tried to re-image the roboRio using Ethernet and it worked. However, in Eclipse when we try and re-upload the code the same error as above occurred.

And yes we have tired restarting the roboRio and the computer, and using a different computer, and using different USB cable.

Any ideas?

Thanks for the help.

0 Kudos
Message 1 of 2


1) did you set your the team number up in eclipse AND on the driver station? in labview this is the first step in making a project if i remember java alos askes for a team number on a new project.

2) did you need to have the driverstation running when pushing code. 

3) i have encountered on occassions where i had to change the setting on the Roborio internet page to disable startup routines save it and restart the ROborio before it would accept code, dont forget to reset the setting after your done 🙂

0 Kudos
Message 2 of 2