FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to create cRIO project using LabVIEW 2013 download

     I'm trying to write some test code on my team's cRIO II (the one from 2012-2014). I downloaded LabVIEW 2013 and the FRC 2014 Update Suite from the links at the bottom of the page. When I tried to create a new cRIO project using the Create New FRC Project Wizard, it threw an error. It says Error 1055 at Property Node in FRC Create Project.vi->FRC Wizard - Robot.vi: Object reference is invalid. When I hit continue (the only option provided), it threw a warning on the  RT CompactRIO and did not add any of the cRIO VIs into the project. It did create the VIs (I can see them and open them in Windows Explorer), but didn't add them to the project. I think the problem is something with the device. Is anyone else having this problem? I would really appreciate it if someone could help me with this. We only have one roboRIO and it's being held up with other testing.

0 Kudos
Message 1 of 3
(3,193 Views)

Hi arimb1999,

Have you tried to use the most recent versions LabVIEW 2015 and FRC Update Suite 2016?  There is a high likelihood that the problem will not show up in the newer version. 

How did you image your cRIO? Did you use the cRIO Imaging Tool or did you use a different method?  Also, which order did you install LabVIEW and the FRC software?  LabVIEW should be installed first in order for the FRC software to correctly install.

Kelli Kravetz
Product Marketing Manager
LabVIEW, LabVIEW NXG, LabWindows/CVI, Measurement Studio
National Instruments
0 Kudos
Message 2 of 3
(2,687 Views)

I imaged the cRIO using the 2013 cRIO Imaging Tool included in the

software. I downloaded LabVIEW before the FRC update. I was around and

programming in 2013, and I didn't have a problem when I did it then so I

can only assume that this is different software than I had in 2013.

0 Kudos
Message 3 of 3
(2,687 Views)