FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Trouble getting relays and digital inputs to work

I have used the example for relay and digital input figure out basic operation to work.   I run those examples, and it worked fine.  Now when I run the digital input, the power light on the digital sidecar goes out and nothing works.  any idea what I did wrong?  If I disable that part of my VI power is restored and all is as it was.  But I need 2 digital inputs for limit switches.

As for the Spike relays, I want to use them to control some solenoids, but there is always a voltage on the the M+ and M- terminals.  Again, it worked for a while, but now, I get about 11 volts. (battery voltage).  I'd'd appreciate some input from the community!  we are a rookie team and time grows short!

0 Kudos
Message 1 of 4

You may have a wiring short on the wiring connected to the digital inputs.

Enabling the digital input with the faulty cable connected to it shorts out the Digital Sidecar.

Are all three Digital sidecar lights showing up as bright green, before this short happens?

If they aren't all three bright green, then the separate power to the Digital Sidecar directly from the Power Distribution Panel is missing.

When your Spike is showing voltage on M+/M- when you don't think it should be:

  • Check the Relay status lights on the Digital Sidecar - should all be off NOT green and/or red
  • Check the Spike status LED - should be orangish/redish, NOT bright green or bright red
0 Kudos
Message 2 of 4


This is a bit late in coming, but thanks for your help!  I found the problem, and we are now operational, with the exception of getting the final program deployed onto the driver station laptop.  Is there a doc I am not seeing?  we have it showing the FRC PC dashboard, and the drive station software.  But where and how to we get the vi to deploy?

I was expecting LabVIEW to generate an installer but it doesnt, or did I miss something?



0 Kudos
Message 3 of 4

From the project explorer window. at the bottom you'll find Build Specifications

Expand that and you'll see FRC Robot Boot-up Deployment

Right-click on that to get the pop-up menu and choose Build to compile your project.

It'll take several minutes.

When it's done, power up the robot and connect to it.

Then right-click for the same menu again and choose Run as startup.

That will begin the permanent code transfer.

0 Kudos
Message 4 of 4