FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Steering backwards

Highlighted

this seems to happen every year, the robot goes forward and back just fine. However left and right are reversed. I don't remember what to tell the team to do to fix it.

it's something like swap the PWM cables for the left and right side and then change the invert motor settings to opposite what they are....is that right or how do you do it?

thanks

"Lockheed" Joe
Testing Blog"
0 Kudos
Message 1 of 2
(2,162 Views)
Highlighted

Hi LockheedJoe,

The solution depends both on the current wiring configuration and the actual code. A couple questions:

Are you using LabVIEW?

What type of drive (Arcade, etc)?

If you're using LabVIEW, can you post screen shots of the Begin.vi where you are setting up the motors and PWM lines, as well as the Teleop.vi where the actual controls are being configured?

Without seeing the code, some steps I would try:

- Invert the motors. This might inadvertently also turn forwards into backwards. If that happens, it might be possible to invert the signal in software by multiplying the value from the array index by -1 before it is sent to the motors in Teleop.vi.

- Switch the PWM lines. Some components could be wired backwards. Either physically reconnect them, or change which lines are for which motors in the Begin.vi.

By troubleshooting one step at a time, you can probably identify where the controls are inverting.

0 Kudos
Message 2 of 2
(1,268 Views)