FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

RoboRio will not communicate over USB


I cannot connect my PC with the RoboRio over the USB connections.  The National Instruments USBLAN Adapter driver is giving a Cannot start error (Code 10).  I have tried reinstalling the FRC Update suite to reload the drivers but this did not work.  The PC has worked over USB in previous years.  The PC can communicate fine over Ethernet and WiFi to the RoboRio, and I was able to deploy code to it. 

Is there a conflict with the driver, and if so, how would I resolve it?


Other PCs are able to communicate over USB with the RoboRio using the same cable.


Any help would be appreciated.

0 Kudos
Message 1 of 10

Hello mgurgol,


If this computer had previously installed the NI software for previous seasons, and has had the Windows OS 10 updates, it is possible you are running into the following problem: My Device Shows up as "Generic USB-EEM Network Adapter" in Device Manager. Does it match your setup?



0 Kudos
Message 2 of 10

It is similar except that the Network Adapter I am seeing is "National Instruments USBLAN Adapter #5" not the "Generic USB-EEM Network Adapter" as described in the article.  I will attempt the steps listed in the article tonight at the shop and see what happens.

0 Kudos
Message 3 of 10

mgurgol, if it is being detected as a National Instruments USBLAN Adapter, I would try Disabling and Enabling the device from Device Manager before moving files in the System directories. Otherwise, go ahead and follow as the document says.



0 Kudos
Message 4 of 10



Enabling and disabling did not have any affect.


I replaced the usbnet.sys driver with the nationalinstrumentsblan.sys as described in the article.  I now see the roboRio, but with IP address instead of


The other PC still sees the roboRio as

0 Kudos
Message 5 of 10

That sounds interesting... seems to be a link-local address used by ethernet. Can you help us with a screenshot of where you are seeing this IP?


If after rebooting the computer it still behaves the same way, I recommend we force-reinstall the Update Suite, to make sure that the driver you just replaced is properly configured: Having An Issue with 2019 Update Suite

0 Kudos
Message 6 of 10

I tried the force install with the FRC Update Suite.  The RoboRio is still not connecting.  I am seeing the in the roboRio Imaging tool on my machine.  It finds the roboRio, and that is the IP address listed.  When I run the roboRio Imaging tool on the other PC the IP address shows up as as expected.


I am going to try and grab the driver from the machine that is working and replace that on my machine to see if that will fix it.  I will keep you updated of my progress.

0 Kudos
Message 7 of 10

I updated with the new FRC Update Suite and showed the same issue.  I then copied the nationalinstrumentsblan.sys to usbnet.sys in windows/System32/drivers directory and am showing National Instruments USBLAN Adapter #5, but the IP address is still as viewed in the roboRio Imaging tool.  I am unable to ping

0 Kudos
Message 8 of 10



I think there is one last test we can try to make your computer associate the driver correctly: go to the Windows Device Manager and under Network Adapters select the National Instruments USBLAN Adapter, then click on Update Driver. Select to browse manually for the software and point the directory to C:\Program Files (x86)\National Instruments\CompactRIO\Staging\USBLAN. Hopefully it finds the nationalinstruments.inf file and can install it. After this, please disconnect the roboRIO and reboot the computer.


If the error persists, please make sure the Ethernet adapter settings for the National Instruments USBLAN Adapter have the IPv4 configured as automatic.


I still find interesting that this behavior happens in just one computer. I am unsure if there would be a Windows OS configuration that would change the expected behavior from the adapter.


All the best.

0 Kudos
Message 9 of 10

I tried to update the driver, but windows says it is already updated.  The RoboRio when plugged in via USB always uses the USBNET.sys driver.  I have copied the nationalinstrumentsblan.sys driver to USBNET.sys and I still do not get the expected IP address for the RoboRio (I get the  Since this is only happening on PC, I am not going to worry about it anymore.  In the off season I will reformat the device and start fresh to see if that helps.  Thanks for all of your help.  Mark

0 Kudos
Message 10 of 10