FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

RoboRio Lockout

We (Team 4926) have recently bought a new RoboRio. We did quick start-up with imaging and firmware, however as we went to download code through Labview, it gave us an error.

Error: This host computer's IP address is not on the target's allowable access list.

We have tried many different approaches, anywhere from re-imaging to switching computers. However everything seems to lead back to the same place. Is there anyway to remedy this or to prevent whatever is causing the error?

Thank you for your help.

-Team 4926

0 Kudos
Message 1 of 3


You can check the User Access settings of your roboRIO through the LabVIEW Project Explorer window. Right click on the roboRIO target, and select Properties. You should then be able to select ‘User Access’ in the left-hand side of the Properties window. I’ve included a screenshot of what this screen should look like. You can also manually add your computer’s IP address to this list. Let me know if this fixes it!



0 Kudos
Message 2 of 3

So we tried your suggestion and now it works once or twice at the beginning of each testing session but then it returns to the error that we had before.Do you have any suggestions?

-Team 4926

0 Kudos
Message 3 of 3