From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

RoboRIO Imaging Error

I am having the same issue with one of our RoboRIOs. I've tried to reimage it using three different computers, using different USB cables and ports, and even tried over Ethernet. I get a dialog box almost the same as in the first post. Here is the text of the dialog box when I last tried (using Ethernet).

Unable to download image to target. Unable to complete

operation because of unexpected error:nisyscfg.lvlib:format

5.3vi:2890001<APPEND>

<b>Complete call chain:<b>

     nisyscfg.lvlib:Format 5.3.vi:2890001

     RoboRIOImagingTool.lvlib:Reconfig Device.vi

    RoboRIOImagingTool.lvlib:ImageManager.vi

    RoboRIOImagingTool.lvlib:ImagingToolMain.vi

I can connect to the RoboRIO over USB or ethernet. I can deploy code, and connect to the system configuration tool. When in the web based system configuration tool, it shows the Firmware Version as unknown.

I cannot update the firmware from the web System Configuration. I click the Update Firmware button, browse to the new firmware file, and click begin update. It shows it starting to update and then comes back with a message at the top the says "There was a problem updating the firmware for this device."

I can connect to the RoboRIO using putty and WinSCP.

Is it possible to transfer the files for updates using WinSCP and then execute the commands from a prompt in putty?

0 Kudos
Message 11 of 13
(2,459 Views)

Hello,

Please give us a call at 866-511-6285 when you have access to your roboRIO. This is the NI help hotline for FRC. We will help you troubleshoot this issue and we can authorize a replacement if the Applciations Engineer decides that the roboRIO needs replacing.

Try to update the firmware again but in Safemode. To get into Safemode hold down the Reset button for approximately 10 seconds. You will know you are in Safemode when the Status light begins flashing three times. If updating Firmware in Safemode does not work then please give us a call.

Brian H. -- Electronics & Measurements Product Marketing Manager
Message 12 of 13
(2,459 Views)

I tried safemode and the status LED blinked continuosly (unrecoverable error). I called NI tech support at the number listed and they resolved my issue. They had me create a bootable flash drive for the RoboRIO. After running a recovery from the flash drive, I was able to image the RoboRIO from the imaging tool. Then I was able to update the firmware to the latest version.

I will not be sharing the instructions to create the recovery flash drive. You'll want to contact NI support if you need to go that route.

Thanks again to NI for the awesome support!

0 Kudos
Message 13 of 13
(2,459 Views)