FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

New CRIO - imaging tool not recognizing modules

We got a new CRIO and the 3 modules this year on the FIRST choice.  We have been trying to image the CRIO but when we bring up the imaging tool or rescan it is not showing the modules in the picture on the right.  That means that the toggle switches on the bottom are disabled so when we try to image we get an error regarding IP Address.

We have tried all the trouble shooting ideas I have found in numerous spots on chief delphi and this forum but nothing seems to work.

1.  We tried with and without the router between the computer and the CRIO

2.  We set our mask to 255.255.255.0

3.  We tried multiple different IP addresses on the computer.  10.XX.YY.5  where xxyy is our team number.  We also matched the ip address of the crio with the last number different. 

4.  We are able to ping the CRIO using it's IP address

Does anyone have any ideas?  Could we have gotten a bad CRIO?

We have our old CRIO and we were able to bring up the imaging tool fine using the same computer.  We can see the all the modules on that device.  We did try the old modules one by one in the new CRIO and they are still not recognized so we don't feel it is the modules.

Please help.

Thanks in advance.  We (I) am going crazy.

0 Kudos
Message 1 of 3
(3,468 Views)

I forgot to put that we also made sure that our other network adapters were disabled and the firewall was disabled.

0 Kudos
Message 2 of 3
(2,792 Views)

zeldaTheGood,

I had a system do something similar during the quick build I helped with. I posted the instructions here:

https://decibel.ni.com/content/message/64263#64263

If memory serves, the modules don't always show up until the image is applied..

But for the IP address issue, try the instructions I posted earlier an post back here and let me know how it goes.

Ryan

0 Kudos
Message 3 of 3
(2,792 Views)