FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

NXT Terminal will not load

I bought a Mindstorm kit so that I could go through the LV presentation with the whole computer team and do some LV training in advance of the cRIO.

Everything works fine on my XP desktop.

On my Vista Home Premium Laptop, I get "An error occurred trying to load the NXT Terminal."  My first guess is a Vista problem.

I uninstalled everything, reinstalled LV, the NXT toolkit, updated the library, and did the mass compile.  The same as on XP.

I can open and view the Solutions Ball Hunter VI, but I can't get NXT Terminal to work.

The other strange thing is that I can't get rid of the expiration splash screen at start up, may not be related - but strange.  I check the box, but it comes back every time that I start.

Any suggestions?

Thanks

Randy Wood

0 Kudos
Message 1 of 6
(8,583 Views)

Randy, I'm using Vista Enterprise with Admin privileges and I had no problem. Make sure you have a new or existing VI open when you try to open the NXT Terminal. BTW, there is a known bug and itt's not unique to Vista. Also, make sure you have "admin" privileges.

0 Kudos
Message 2 of 6
(981 Views)

Thanks for the response, but no joy in Mudville.

I have admin privileges and I have the BH Robot.vi from the NI presentations to FRC teams open.

NI web site says support for Vista, doesn't say what versions are supported.  If none are specified, I assume that means that all are supported.

0 Kudos
Message 3 of 6
(981 Views)

Hi Randy,

It sounds like you have taken some good troubleshooting steps.  Did you uninstall everything through the Windows Control Panel?  Also, which version of LabVIEW are you using?  Did you download the toolkit and patch from http://zone.ni.com/devzone/cda/tut/p/id/4435?  

I am in the process now of installing the NXT Toolkit on a Vista machine to see if I get the same error.  

Regards,

Jennifer

Jennifer R.
National Instruments
Applications Engineer
0 Kudos
Message 4 of 6
(981 Views)

Hi Jennifer,

Thanks for the response.

Yes, I uninstalled everything via the control panel.  I am running 8.5.1 downloaded from the FIRST link that was emailed out with the FRC license.

I downloaded NXT from the link on this page http://digital.ni.com/express.nsf/bycode/expf2x?opendocument&lang=en&node=seminar_US it points to http://oclabview.com/Public/Knapp/NXT_Download.zip

Now for the update.  I uninstalled NXT toolkit and driver (again) this time when I installed, I made sure that both anti-spyware and anti-virus were disabled.

Now the NXT terminal loads, but it can't find the robot.  I tried rescanning, but it isn't found.  LEGO MINDSTORM NXT shows up in the device manager, I got a successful installation message when I connected the robot and I get the tones when I disconnect and connect the robot..

I'm also having a problem running the sound exercises from the above link.  I have tested the code on my XP machine and tried to run them on my Vista machine.  All I get is the simulated data.  I have had the recorder running at the same time as LV and get a recording of the tone that I am generating on another computer so I believe that the sound system is working.  After some time reading about debugging and drilling down into the vi's, I found that Sound Input READ (dbl) is getting an error 4823 - Labview - Hex 0x12d7 A task must be running for this operation (or words to that effect).

It hasn't been a complete waste of time, I know a lot about breakpoints and probes now.

I'll try downloading from your link, just in case.

If you have any suggestions on either problem, I like to hear them.

Thanks

Randy

0 Kudos
Message 5 of 6
(981 Views)

I had the same problem in Vista. When launching Labview, remember to Right-Click on it, and choose "Run as Administrator". Worked for me!

Jeff

0 Kudos
Message 6 of 6
(981 Views)