FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

NI LabView for FRC 2013 install failing: "setup.exe has stopped working"

I'm setting up a new computer as a development/driver's station. It's running Windows 7 64-bit (fully patched). When I run the "install everything" option off of the DVD from the Kit of Parts, each of the eight components starts to install and then (at varying degrees of completion) throws up this not terribly illuminating error:


I have the option to continue installing (as descibed here) and at the end I'm presented with the same list of software not installed.

I've dug around in the event logs, and all I'm seeing is a general application error that looks like this:

Faulting module name: nvinit.dll_unloaded, version, time stamp: 0x50de924b

Exception code: 0xc0000005

Fault offset: 0x74bbce59

Faulting process id: 0x380

Faulting application start time: 0x01cdf73f99015f82

Faulting application path: D:\Resources\Distributions\LabView 2013 Patch\setup.exe

Faulting module path: nvinit.dll

Report Id: fc18ae72-6332-11e2-bf8a-2016d890e817

I've tried getting out ahead of the installer re-installing the .Net Framework ahead of time (it was complaining that it needed to install that first, as it had on other computers with the same image -- perplexing). I've tried completely uninstalling everything from National Instruments and reinstalling. I've turned off my firewall. I'm a local admin on the machine.

Any ideas? This install worked fine on two other freshly-imaged machines running Windows 7 64-bit.

0 Kudos
Message 1 of 4

Oh, and, as soon as I "finish" the install, the NI Update Service pops up with a series of updates:

  • LabVIEW 2012 Real-Time Module f1 Patch
  • LabView 2012 (32-bit) f3 Patch
  • NI-Serial 3.9
  • LabView 2011 Sp1 f2 (32-bit) Run-Time Engine Patch

setup.exe stops working on each of the patches (unsurprisingly).

0 Kudos
Message 2 of 4

Hi Seth,

Based on the thread you mentioned with a similar issue, have you tried running the updates or starting up LabVIEW? The software may be functioning despite the errors. Install/repair installing the disc and update contents is also a good idea. You can try copying the disc contents and running them from the local hard drive. You can also right-click the setup.exe and select Run as Administrator.

If you are still having problems and have an nVidia video card, you may want to check your driver version. Instructions on how to check the driver version can be found here:

Some installation issues have been resolved by rolling these drivers back to version The instructions for rolling back can be found here:

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 3 of 4

cZach, it looks like just ignoring that the installers failed and plowing ahead works. I ran the various 2013 season updates and things (seem) to be working normally.


0 Kudos
Message 4 of 4