FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

LabVIEW Development System Installer skips all sub-installers

One of our students got into a situation where the LabVIEW Development System installer (not the FRC update) skips through all its sub-installers even though the C:\Program Files (x86)\National Instruments folder does not exist...


I may not have all the steps but this is what I understand happened.

  1. Tried to change the install directory to a flash drive and install LabVIEW.
  2. Probably deleted the folder that was installed to.
  3. Now does not have that flash drive in the computer.
  4. Changed the install directory to something like "My Documents\LabVIEW 2018" and installed LabVIEW there.
  5. Deleted that folder.
  6. Uninstalled via control panel.
  7. Now we try to install LabVIEW to the correct folder and each sub-installer comes up for a few seconds and goes away.

We're not sure how to remove LabVIEW as the National Instruments entry in the uninstall section of Control Panel does not exist. We tried invoking the /reinstall switch with command prompt but the setup.exe does not appear to recognize that switch.


Any ideas how to get LabVIEW properly installed without reinstalling Windows?

0 Kudos
Message 1 of 3

Hello JonathanLindsey,


That's one interesting situation. I agree with you that deleting the folder would not have removed the rest of the dependencies that are installed in the OS and other file locations (therefore "confusing" the installer into thinking that the software is already in the machine).


Please follow the instructions in Force Reinstall Non-Working or Corrupt NI Software and run each setup.exe located under the installer's Resources\Distributions starting with LabVIEW 2018, then LV RT 2018, VDM 2018, IMAQdx, FRC RIO, FRC Simulation.


Let us know your results.

0 Kudos
Message 2 of 3

We are working on this it is just taking time. I will get back to you.

0 Kudos
Message 3 of 3