FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Installation errors in VMware Horizon View client

Go to solution

I am trying to install LabVIEW in a VMware Horizon Client virtual workstation, but the installer has generated a long string of error messages for every component similar to this:


The "NI Uninstaller 17.0.0" installation has failed with the following error:

The Windows Installer does not permit installation from a Remote Desktop Connection.


The Horizon View client has options to connect via either a PCoIP protocol or Microsoft RDP, but I am using the PCoIP option and this is NOT a remote desktop connection. Is it possible to install in this type of environment?

0 Kudos
Message 1 of 6
Accepted by topic author Andrew.Ballard

Hello Andrew.Ballard,


Can you describe us the way you're installing the software in your Virtual Machine?


a) Are you downloading it from the NI's website, or are you using an installation media (DVD, USB)?

b) Which products are you installing? Are you installing the FIRST Robotics Competition (FRC) software? Or just LabVIEW Professional, or a specific suite?

c) Are the installer files in the VM before you run the Installer? Are you using remote units to execute the installer from (is the installer using resources from a network device, or perhaps transferring them from your Hard Drive to the VM partition)?


I see a document that could give more insight as of why this error happens: Windows Installer does not permit installation via RDP


Let us know your results.

0 Kudos
Message 2 of 6

I am running the setup off of a thumb drive. The file was downloaded from the web. So far all I have tried is the LabVIEW Professional software with all the default options. I hadn't thought to copy the files to a drive local to the VM in case that makes a difference. I can try that.

0 Kudos
Message 3 of 6

Hi Andrew.Ballard,


Please try copying them to the VM and let us know your results. If you see an error, try to take a screenshot to share it with us, since it might provide some information as of what could be happening with the installer.

Message 4 of 6

That seems to have made the difference. Usually our VMs have USB redirection enabled so that thumb drives appear mounted as local devices in the virtual client. I hadn't really thought much about the fact that right now our VM administrator has USB redirection disabled, so the thumb drive was mounted as a share from the physical machine instead. Running the installer from a local file looks like it worked.

0 Kudos
Message 5 of 6

That's great to hear,  Andrew.Ballard.


Thank you for letting us know this result, and make sure to mark the appropriate post as answer for future related questions!


All the best!

0 Kudos
Message 6 of 6