FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Failure to deploy code - "Deployment completed with errors"

We are using the Command and Control framework, and one of the subsystems includes a channel between the sensor processing and the command loops. The channel is a 'Tag' type.


When trying to deploy to a different roboRIO, the deploy fails on this subsystem. Commenting out the subsystem allows the deploy to succeed. With no real error messages it is hard to determine what is actually failing, and none of the VIs are broken. The last deployed item is a function from the channel. Here is the end of the log:


Deploying FPGA_DIODigitalSourceChannel.ctl (1.49 K)
Deploying Subsystem Sequencer Get (4.35 K)
Deploying Tag-a[.](t'Wheel of Doom Slot State.ctl').lvlib:ChannelOp.ctl (1.49 K)
Deploying Tag-a[.](t'Wheel of Doom Slot State.ctl').lvlib:)) (31.07 K)
Deploying Tag-a[.](t'Wheel of Doom Slot State.ctl')
Deployment completed with errors

Free Memory: 70751 K of 250152 K Total (28%)


The one thing tried was going to Tools --> Advanced --> Clear Compiled Object Cache...


The underlying type is:


(1D array of)

       (typedef 'Wheel of Doom Slot State.ctl'[non-strict])

                 (cluster of 2 elements)

                         (boolean (TRUE or FALSE))

                         (boolean (TRUE or FALSE))


Is there any way to see what errors this produced, any any recommendations on the correct way to fix this?

0 Kudos
Message 1 of 2

I saw this problem with my team, too. We also tried clearing the Compiled Object Cache (we do are using custom LabVIEW classes), as well as restarting both LabVIEW, the roboRIO, and the computer itself.


Oddly, the behavior just happened in one of our laptops. The other ones, with the same code branch checked out (i.e. the same code that failed in this one computer) did not fail in deploying. At that point, I just set all the NI software to repair using the NI Package Manager. I also reinstalled third party libraries, just in case.


Unfortunately, I am not sure if the fix worked, because the meeting ended before the software finished repairing. For now, our solution is to be cautious with that machine.


I have not been able to replicate the problem in other computers. If we can get a consistent sets of steps or process that makes the problem show up, then I would like to report it and investigate further.


I hope this helps,

0 Kudos
Message 2 of 2