FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

FRC roboRIO Not Imaging No Matter What

Solved!
Go to solution
Highlighted

Hello all,

 

Recently I have been struggling with my FRC roboRIO's imaging sequence, as whenever I attempt to format it, it fails. The message from the Imaging Tool included in FRC Game Tools reads

```

Unable to download image to target.

 

Possible solutions:

...

 

Possible reason(s):

 

NI System Configuration: Cannot open file or folder.

 

Complete call chain:

nisyscfg.lvlib:Format.lvlib:Format 5.3.vi:2890001

RoboRIOImagingTool.lvlib:Reconfig Device.vi

RoboRIOImagingTool.lvlib:ImageManager.vi

RoboRIOImagingTool.lvlib:ImagingToolMain.vi

 

Status: corrupt firmware, cannot run

```

 

I have tried the given solution, and did not want to spend writing them down. I have also tried the NI MAX which failed as well. I have read several other threads, and I still have yet to find one with an error like mine. I am really, really lost and would appreciate any help.

 

Thanks

0 Kudos
Message 1 of 3
(283 Views)
Highlighted

I'm likely going to ask some questions that you've already tried.  I'm not sure what you've read to provide given solutions so I won't know which things you've tried.

 

What is the status light on the roboRIO doing?

You've tried MAX.  Did you do this in Safe Mode with a Format or did you do something else?

What's the name of the roboRIO in MAX?

Have you tried multiple PCs?

Are you connected via Ethernet or USB?

Is this a fresh roboRIO or are you upgrading an install from past seasons?

0 Kudos
Message 2 of 3
(234 Views)
Highlighted
Solution
Accepted by topic author KryptonCougars

I solved the issue. I apologize for forgetting about this post. Thank you for the response however! I solved it by running the following command and rebooting. 

nisystemformat -f -t ubifs && nisystemformat -f -t ubifs -c

Thanks anyway! 

0 Kudos
Message 3 of 3
(230 Views)