FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

FRC 2019 robotRio Imaging Tool cannot find firmware?

My roboRio Imaging Tool tells me I need firmware V5 or later. Great. When choosing the "Upgrade Firmware" option, the "Select Firmware" field is empty. The example shown in screensteps shows a  firmware filename of: roboRio_6.0.0.cfg. Looking on my system, I have that file here:

 C:\Program Files\National Instruments\Shared\Firmware\cRIO\76F2\

Why isn't the imaging utility finding it? On a lark, I copied it to C:\Program Files\FIRST\NI\LabVIEW 2018\project\roboRIO Tool\FRC images which is where the tool seems to look for "Format Target" zip files. No joy. 


This is failing for me on two separate Win 10 laptops, both with FRCUpdateSuite_2019.1.0 installed. 

From the forums, the workaround seems to be to bail and try NI Max. Trying that now.  



0 Kudos
Message 1 of 4

I will check my system (Win10) this evening. 

I just updated the firmware on two RoboRio's today.... 

0 Kudos
Message 2 of 4

OK, After downloading all 4GB of the NIMAX download it was a bust. I never could see the Rio on the address. According the instructions here:

the Rio has to show up under Remote Devices. I couldn't get that to happen. 


What finally worked. I was able to use Internet Explorer and the 2018 web interface (silverlight) to do the firmware update. Then the imaging tool was able to install the rest of the 2019 bits and I'm good to go. Wish I had tried that 4GB sooner....

0 Kudos
Message 3 of 4

 Wish I had tried that 4GB -> hadn't tried....

0 Kudos
Message 4 of 4