FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Ethernet Trouble


Our roborio shows comms as green, but is not reading the radio. We tried switching the roborio and the cable already, it does not change anything. However the driver station reads the radio, but not the Ethernet. How can I fix this?

0 Kudos
Message 1 of 4

Hello Samuelyashch,


I would start with the steps here: Unable to Connect to roboRIO in Driver Station, Imaging Tool or LabVIEW.


I think having more information about your setup can help us be more effective in providing possible solutions and next steps. For example:

  1. Which is your network topology? (what is connected where)
  2. Are you using the radio or you are connecting by Ethernet from the Computer to the roboRIO directly?
  3. Have you configured your radio for the 2019 season? Were there any errors?
  4. How about ping results?
  5. Screenshots would also be helpful.


All the best,


0 Kudos
Message 2 of 4

We ended up just re-writing all our code, and it worked. So it was a code error.

0 Kudos
Message 3 of 4

Thanks for letting us know, Samuelyashch. I am glad it is working again.


All the best,

0 Kudos
Message 4 of 4