FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Drive Station, Dashboard and cRIO imaging tools start on Taskbar then stop, no errors displayed

Solved!
Go to solution

I cannot get any of the above programs or tools to run on my computer. They all start a service and then stop. The application shows in the Task Manager and on the Windows taskbar. These programs all worked for the competition season. 

I have performed the following to troubleshoot the issue:

Shut off the firewall,

uninstalled and reinstalled all of the FIRST software.

I created a new Dashboard project. It will run as a VI but when it is built and run.

Is there a procedure to find out why it has this behavior?

Computer is a Dell E6520 with Windows 7 64 bit. The application has been set to run in 32 bit mode.

0 Kudos
Message 1 of 5
(3,486 Views)

Hey Gregg,

Where did you install from? Did you also get the udpates from online?

Have you tried running as an adminstrator (right click menu)? Any anti-virus software that might be interfering?

Am I correct in my understanding that this worked for you previously on this machine?

Kevin Fort
Principal Software Engineer
NI
0 Kudos
Message 2 of 5
(2,380 Views)

Kevin,

I was a CSA last year and all of the updates were downloaded during the competition season. All of these programs worked on this computer from January through April 4. 

I have run as administrator.

I have turned off Symantec End Point protection and turned off the WIndows Firewall.

The programs all start and show up in the Task manager and on the Task Bar but no User Interface is displayed. After 4 seconds, the programs disappear from the Task Bar and the Task Manager.

0 Kudos
Message 3 of 5
(2,380 Views)
Solution
Accepted by topic author GreggRupp

I now have this issue fixed. It seems as though one of the LabVIEW updates deleted some files. There are files stored in the %temp% when the program is run. It has the following error on one of the lines:

DWarn 0x3169903: InitTDRTableLoader: error(7) opening "C:\Program Files (x86)\National Instruments\Shared\LabVIEW Run-Time\2012\tdtable.tdr"

The LabVIEW 2012 f3 patch did not fix this. The LabVIEW repair did not fix this.

I downloaded the LabVIEW 2012 Run-Time Engine ran it and used the Repair function inside of it.

0 Kudos
Message 4 of 5
(2,380 Views)

Hey Gregg,

Glad to hear you got it figured out!

I believe the issue you ran into is related to installing software while some LabVIEW based application is running. Its actually a problem we've run into with the microsoft installer we use. 

What essentially happens is if modifications get installed to the run time engine while its running some essential pieces of it can get removed after rebooting, thus breaking the run-time engine. Its a pretty rare issue, but R&D is working on implementing a way to keep it from happening in future installers.

Repairing the run time engine, or installing a patch that modifies the run time engine, F3 patch for example (if previously installed you would need to force reinstall it) when completely closed out of LabVIEW and any LabVIEW based applications should fix the issue. It looks like you were eventually successful with the first route. 

I wish I would have seen this sooner, I might have been able to save you some time.

Kind Regards,

Zach

Applications Engineer
National Instruments
CLD Certified
0 Kudos
Message 5 of 5
(2,380 Views)