FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Create a New Subsystem Not Working in FRC 2020


Just installed Labview FRC 2020 and tried to create a new subsystem which did not work. When I opened my project, I right click on RoboRIO target and click on New >> Subsystem but there is no popup. Instead there is a new item called VI-Based Object. I tried this with a brand new clean project and also last years updated project - same result. See below for new item created.  


Has anyone else tried creating a new subsystem and had this same problem or success with it?






0 Kudos
Message 1 of 3



I also posted this to Chief Delphi and someone found a workaround. Here is the link.


0 Kudos
Message 2 of 3

Here is the fix. Extract the attached file into your LabVIEW 2019 folder. You can either extract it directly, or copy it first and then extract it. If you copy it first, you may want to delete the zip file when finished.


When you extract you should get a dialog telling you the destination already has a file named "Rename". Choose Replace the file in the destination.


The result is you should end up with this file replaced:

\LabVIEW 2019\resource\Framework\Providers\FRCSubsystem\Rename

Message 3 of 3