FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Camera responds when pinged but does not show up on driver station.

Solved!
Go to solution
Highlighted

I am the coder/wiring captian for my robotics team and for some reason our ip camera is not showing up in the driver station. I have pinged the ip that the camera is set to on the bridge and it responds with 0% packet loss. We have tried to re-install the driver station and all the 2015 updates we can connect to the robot wirelessly and over LAN connection but never the camera. I don't understand what i'm doing wrong. Any help would be appreciated. Thanks!

0 Kudos
Message 1 of 7
(3,968 Views)
Highlighted

What I found that the RoboRio and the Dashboard try to use the IP address alias of "axis-camera.local". What I had to do is hardcode the IP address for the camera to get the video to come up on the Dashboard. However, since the camera sets it's IP based on DHCP, the camera IP can change from powerup to powerup.

I changed a global variable of "camera IP" that goes into the vi labeled "Dashboard MJPG". I changed the camera IP to be static so I would know where it is...network-wise.

It appears that axis-camera.local is not set up correctly. I'm not sure exactly where to set that up (hosts maybe?) but NI could let us know how to set up axis-camera.local to use the correct IP address.

0 Kudos
Message 2 of 7
(1,889 Views)
Highlighted

You can set the host name in the camera website. Not sure why the camera setup tool doesn't set it. 

0 Kudos
Message 3 of 7
(1,889 Views)
Highlighted

Thanks, I see how it works. My camera host name was set to axis-<wierd stuff>

For everyone's info, connect to your camera through the browser

select setup (top of page)

on side of page select System Options >> Network >> TCP/IP >> Advanced

under the heading Host Name Configuration select the Use the host name radio button

enter axis-camera       NOTE: don't add .local, it doesn't take it and it works out to axis-camera.local

Thanks Science whiz

0 Kudos
Message 4 of 7
(1,889 Views)
Highlighted

I am glad you guys were able to find a solution. Just for reference FIRST does provide a configuration guide for the Axis camera found here:

http://wpilib.screenstepslive.com/s/4485/m/24194/l/144985-configuring-an-axis-camera

I want to point out FIRST also has other getting started guides for the 2015 control system on their website, so I recommend everybody gets familiar with these documents. This will make setup and troubleshooting easier in the long run. Good luck with the competition!

0 Kudos
Message 5 of 7
(1,889 Views)
Highlighted

The problem is that neither of the two methods in that document work with the settings that LabVIEW uses. The Camera config tool sets it to DHCP, but does not set the host name. The manual setting sets to a static IP address, but does not set the host name. LabVIEW requries the host name be set.

0 Kudos
Message 6 of 7
(1,889 Views)
Highlighted

Sorry I had a parralell thread going:

Check out "Dashboard will not connect and display Axis camera M1011 or M1013.

FS

Signal Mtn TN HS and Chattanooga, TN Area High Schools Programming Support

0 Kudos
Message 7 of 7
(1,889 Views)