FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

CAN Problem- Talon SRX motor controllers glitch ever 65 seconds

So we were running last year competition robot getting ready to depoly code we had made for a arm mechanism were adding to this years robot. Before deploying any code we first noticed that our robots Talon SRX motor controllers were shutting down causing the robot to shake.  We then noticed that it was occurring every  65 seconds.Thinking we had a bad RoboRio we installed a new one. No change.  So we thought we had corrupt code so we wrote a new program to run only the drive wheels. Still having the same issue. 


So this is what we're thinking... This summer we were at the WVRoX competition  West Virginia while there there were some robots that were having issues with a Virus that had something to do with Phoenix. 


Any Ideas?




0 Kudos
Message 1 of 3

Let's be a bit more careful with our wording.  It's very unlikely you were seeing a virus and more likely you were seeing a bug in code somewhere.


Midway through last season, CTRE updated their VIs for LabVIEW support of the TalonSRX.  When did you last update your CAN support?

0 Kudos
Message 2 of 3

Soooo this is what we discovered.  Yes.. We did install updates on the motor controllers last season. However...With that suggestion we went ahead and installed the newest updates. Still had the same problem. 


By accident we noticed on the dashboard there was a counter that was attached to a  Ni error code 44061 that occurred approximately ever 65 seconds. Thinking that there was a loop issue we wrote a very basic 2 motor controller program and still had the same issue. 


These are all the things we tried with no success: 

-Changed RoboRio's

-Changed radios

-Updated NI

-Updating Motor controllers 


Rabbit hole that lead to a solution.

-tested a new mother board with new motor controllers with a new NI and FRC updated Windows 10 computer. No problem!  We then went back to the robot with the new computer and ran same code no issues!  Tested it with the old computer (with all the updates) still had the 65 second loop code.  We're still not sure why  the new computer worked and the older computer didn't, but we're back in the game!


The only thing that could have caused the problem was our 4 year old, windows 8.1 computer's, Wifi was not keeping connection with the robot.  The robot was somehow loosing communication with the computer and sometime afterwards it would cause the CAN system would shutdown for a split second. Then it would refresh communications and everything would work for 65 secs. How it came up with the loop code CLUELESS.   AGAIN this is just a HUGE guess. 

0 Kudos
Message 3 of 3