Dynamic Signal Acquisition

Showing results for 
Search instead for 
Did you mean: 

Multi-Device Tasks, DSA, and RT Embedded Controller : Start Task Error

Multi-Device Tasks, DSA, and RT Embedded Controller : Start Task Error

After speaking to an NI App Engineer for about a week now with a resolution pending, it was mentioned to make a post about my problem. I am developing a large PC User Interface for acquisition, sensor calibration, and data logging, with RT code to match which is a command-based architecture that handles strictly acquisition of multiple PXI-4472B devices for UI streaming AND time-history data points, but not simultaneously. After reading the DSA User Manual, it was evident that in LabVIEW 8.0 and on, the multi-device task would handle synchronization of multiple devices without all of the signal routing required explicitly. First, I'll give my system specs:
PXI-1044 14-slot rack
PXI-8106 RT Controller (RTOS, not Windows)
6x PXI-4472B DSA devices(starting in Slot 2)
LabVIEW 8.2 Pro Dev System, with RT of course
The rack is connected to the PC through the ethernet NIC.
Getting to the issue, when acquiring data from a single 4472B, the DAQ configuration works fine and continuous acquisition executing without any time-related errors or buffer overruns. As soon as I configure channels from multiple 4472B's in the same task, error -200452 occurs at DAQmx Start Task.vi, with a further description as follows:
Measurements: Specified property is not supported by the device or is not applicable to the task.
Property: HardwareCompressionEnabled
Channel Name: PXI1Slot2/ai0
I have disabled all property nodes used to set device-specific parameters such as coupling, IEPE excitation, etc, as well as DAQmx Read properties to handle waveform data format, buffer overwrite handling, etc. I have written my own simple VI to just acquire data targeted to the RT controller, which also gives the same error. I have received a VI from the App Engineer which he ran himself with "simulated" devices on his PC, which also gives the same error when targeted to the RT controller.
Am I the only one having this problem? Is it the case that these "multi-device" tasks only work for PC-based acquisition?
I would appreciate any help available! I have been coding in LabVIEW for almost 5 years now, starting in 7.0, and this isn't the first time I've ran into a problem that documentation has been non-existent(at least to my hours of searching) on the forums or the website.
Thanks to anyone and everyone,
0 Kudos
Message 1 of 3

Re: Multi-Device Tasks, DSA, and RT Embedded Controller : Start Task Error

This was reported to R&D (#95588) for further investigation.  There is not a known workaround for the error at this point.

I have tested a different but similar setup and I was able to verify that a multiple device task (i.e. AI channel expansion) does work with DAQmx 8.5, LabVIEW RT 8.2.1 and a PXI-4472 and also with the latest versions of DAQmx and LabVIEW RT. Here are the details of the test setup. At the time of the test I was unable to find a PXI-8106 RT controller.

Tested Setup:


PXI-8186 RT Controller (RT OS)

2x PXI-4472 DSA devices (starting in Slot 2)

LabVIEW 8.2.1 and LabVIEW RT 8.2.1

DAQmx 8.5

Jared T.
0 Kudos
Message 2 of 3

Re: Multi-Device Tasks, DSA, and RT Embedded Controller : Start Task Error

I downloaded and installed the newer DAQmx 8.6.1 driver, executed my code with the multiple device task and everything works as documented. I would assume that it's just a small driver issue with DAQmx 8.5 and my particular hardware setup. Hope this is helpful to anyone else who runs into this problem. The good thing is, all you have to do is update the DAQ driver, and voila!, works like a charm. Thanks for all the help.
0 Kudos
Message 3 of 3