Driver Development Kit (DDK)

Showing results for 
Search instead for 
Did you mean: 

acquireBoard fails

Go to solution

acquireBoard fails

Hi to all,


a few weeks ago I posted a question about my companys new project (driver development for NI M-Series in a Windows XP / RTX environment).


A few days ago I received the hardware (a single PCI-6250 Card) and started the project.


As first step, I planned on compiling the Windows samples, get the basic functions to work, and then move on from there. I am working on a Windows XP-only system for now, RTX will be included at a later stage.


I was able to compile the examples and the nirlpk.sys driver without any problems, but when i run the aiex1 example the "acquireBoard" function will always fail.


It seems like the device list "tDeviceList list(nirlpInterfaceGuid)" is not created properly ... the list is always empty.


The card itself seems to be working fine, since I can see in the Measurement & Automation Explorer.


Does anyone know what could be the cause of this?


Thanks in advance.

0 Kudos
Message 1 of 3
Accepted by topic author reini1981
08-27-2015 04:09 PM

Re: acquireBoard fails



From your description, it doesn't sound like the board is actually using the nirlpk.sys for the driver.  Since you have Measurement and Automation Explorer...I'm assuming that you have DAQmx installed on this system and that the DAQmx driver or nipal.sys is actually getting used.  In order for the nirlpk.sys driver to be able to be called by acquireBoard, it must be the driver for the board.


Updating the driver in device manager to the nirlpk.sys driver would be the first step to getting this working.  You may need to get rid of DAQmx...I have not tried to use our DAQ boards through the MHDDK with DAQmx installed on the system.



Steven T.

0 Kudos
Message 2 of 3

Re: acquireBoard fails

Hello Steven,


thanks, you solved the problem.


I was a little confused, because the MHDDK readme just states to copy the nirlpk.sys to the windows/system32/... folders. Since I already installed DAQmx and the standard driver, I never thought about this. Of course it all makes sense now.


Best regards,


0 Kudos
Message 3 of 3