Distributed Control & Automation Framework (DCAF)

Showing results for 
Search instead for 
Did you mean: 

Building editor as an executable - plugin not found "CEF::class discovery singleton"

I need to create an executable version of the DCAF editor for my application that has several custom modules. By piecing together some comments on that topic by BeCega on Github here and  here. I have been somewhat successful in getting the build to complete and it looks like I can create new configurations using my custom module classes. They show up in the "other" category after adding a target and standard engine to a blank config. 


However, problems arise when opening an existing configuration. The built executable editor will not open any of my existing configuration files that were created in the non-executable editor (i.e. the shipping editor that launches from Tools>DCAF>Launch Standard Configuration Editor). The error is something along the lines of "One or more plugin modules were not found... Original error text: CEF::class discovery singleton" (see attached screen shot).


And when I  save and re-open a bare-bones configuration from within with the executable version, I get a similar error "One or more plugin modules were not found... Original error text: find instance.vi" (see attached screen shot).


I have attached screen shots of my project hierarchy, my build settings showing that all of the classes and associated VI's get copied into a folder named "classes", along with screen shots of the actual error. 


See the attached "editor error" screen shot for details. I tried adding the System.lvclass to my "Classes" folder as an always included item, it didn't make a difference. I also have attached screen shots of my project and destination folder settings for reference, I'm using the same layout recommended from that Github post. 


Even if I do get this to run properly on my development system as an executable, since it rely's on the VI's and classes in folders with the executable, will it work on a system that does not have a full licensed copy of LabVIEW (i.e. just runtime)?


Message 1 of 2

I realise I'm resurrecting an old post here but did you get to the bottom of why all the modules ended up in the 'other' group?

edit: worked it out: https://forums.ni.com/t5/Distributed-Control-Automation/Editor-as-an-Executable-Modules-only-appeari...

Message 2 of 2