Discussions au sujet de NI LabVIEW

annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 

"Lisser" un signal aléatoire ?

Bonjour à tous, 

 

Je cherche à reproduire un signal aléatoire, j'ai réussi a gérer la plage de fréquence de celui-ci ainsi que son amplitude. Une seule chose me pose problème, son allure.. Je vous laisse constater à l'aide de ces deux photos mon problème.

Signal à reproduire : 

ni 1.png

Mon signal :

ni 2.png

 

Voici le bloc qui génére ce signal : 

ni 3.png

 

Quelqu'un a-til une idée de comment " lisser" mon signal ??

Cordialement

0 Compliments
Message 1 sur 49
4 056 Visites

essais de comparer les 2 spectres en fréquence

0 Compliments
Message 2 sur 49
4 049 Visites
Tu ne sais pas d'où peut provenir cette "saccade" ? Les plages de fréquences sont identiques...
0 Compliments
Message 3 sur 49
4 039 Visites

n'existe-t-il pas une méthode pour moyenner ce signal et éviter d'avoir tous ces pics? 

0 Compliments
Message 4 sur 49
4 023 Visites

la sonde de mesure n'est pas la même entre les 2 mesures !?

en haut on a pas un bruit blanc

il y a des pics et un bruit "régulier" a plus haute fréquence

une visualisation sous forme de spectre serait plus parlante

 

0 Compliments
Message 5 sur 49
4 020 Visites

Non j'ai pris une sonde pour une mesure et l'autre mesure est faite en direct. L'osccilo est correctement paramétré ! quel est le type de signal de la premiere photo si ce n'est un bruit blanc gausseen?

0 Compliments
Message 6 sur 49
4 013 Visites

voila le premier signal mesuré avec une sonde : 

ni4.png

0 Compliments
Message 7 sur 49
4 004 Visites

as tu un analyseur de spectre ?

 

0 Compliments
Message 8 sur 49
3 995 Visites

Re,

 

Je  viens de regarder j'ai a disposition 3 analyseurs de spectre mais leurs bandes passantes est trop importante pour pouvoir mesurer mon signal ! Y a -t'il une autre solution?

 

cordialement

0 Compliments
Message 9 sur 49
3 982 Visites

Je pense avoir trouvé mon erreur, en effet j'ai ouvert beaucoup de VI pour chercher mon erreur et je suis tombé sur celui-ci " average sin wave noise". Je pense que la principale différence entre ces deux signaux c'est que moi je produits un bruit non moyenné contrairement à celui que je cherche à reproduire.

 

Il y a une partie de mon programme que j'avais pris sur un exemple qui fonctionnait avec du " FPGA " que voici : 

1.png

voici comment j'avais interprétré ce code en DAQmx : 

2.png

 

Comme tu peux le constater, il y a une partie qui est différente entre un matériel daq et fpga, c'était "elements remaining" et j'avoue avoir négligé cette partie... Comment puis-je l'intérpréter et par quoi puis-je remplacer cette fonction à l'aide du matériel que j'utilise?

 

 

0 Compliments
Message 10 sur 49
3 971 Visites