Discussions au sujet de NI LabVIEW

annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 
Répondre

Problème temps labview

Problème temps labview

Bonjour, je suis actuellement en train de réaliser un petit projet de banc d'essai pour du modélisme de voiture de course et j'aimerai mesure la vitesse des roues ainsi que la vitesse du rouleau du banc d'essai. Pour cela j'ai utilisé une NI-6009 et un DAQAssistant. ma fréquence d'affichage sur graph est de 1000Hz et j'ai 2 courbes, ces 2 courbes représente la vitesse du rouleau et de la roue et celle-ci doivent etre confondu pour prouver une bonne adherance sur la piste. Cependant un probleme persiste... je dois faire en sorte de stopé l'acquisition au bout de 10 secondes et je n'arrive pas à obtenir un temps correct. de plus sur le graph ma valeur minimal et maximum sont énorme ! (3,57364E+9) et quand j'essaye d'obtenir un temps avec un bloc fonction de labview comme le "Temps ecoulé" ou "valeur de l'horloge en ms" ça ne marche pas :/ .

J'aimerai savoir si vous avez une explication ou une solution à mon probleme.

 

Merci d'avance.

Voici mon VI (Je suis sur Labview 2011)

Message 1 sur 32
720 Visites

Re: Problème temps labview

si tu veux que ton graphe soit rafraichi 1000 fois par seconde il faut ajouter un délai de 1ms à l'intérieur.

 

C'est probablement trop rapide, normalement l'oeil humain ne percoit pas les changements plus rapide que 100ms

 

10Hz est probablement suffisant, mais c'est peut-être nécessaire de faire ton acquisition à 1000Hz, tu peux faire deux boucles parallèles, une cadencée à 1ms et l'autre à 100ms qui récupère les données d'acquisition et rafraîchi le graph.

Message 2 sur 32
694 Visites

Re: Problème temps labview

Votre valeur 3,57364E+9 correspond au nombre de secondes écoulées depuis le zéro de LabVIEW et "maintenant" (LabVIEW calculates this timestamp using the number of seconds elapsed since 12:00 a.m., Friday, January 1, 1904, Universal Time [01-01-1904 00:00:00] - désolé, j'ai LabVIEW en anglais).  Vous devez donc soustraire à votre échelle de temps votre temps zéro, soit votre valeur minimale.

Jean-Marc
LV2009 and LV2013
Free PDF Report with iTextSharp
Message 3 sur 32
693 Visites

Re: Problème temps labview

Et comment faire ? Avec une waveform ? Ou directement dans le graph ?

Message 4 sur 32
689 Visites

Re: Problème temps labview

0 Compliments
Message 5 sur 32
682 Visites

Re: Problème temps labview

Merci ! C'est compatible avec le DAQassistant ?

0 Compliments
Message 6 sur 32
678 Visites

Re: Problème temps labview

Aucune idée, je ne me sers jamais du DAQ assistant.  J'utilise plutôt les fonctions de base...

Jean-Marc
LV2009 and LV2013
Free PDF Report with iTextSharp
0 Compliments
Message 7 sur 32
675 Visites

Re: Problème temps labview

Bonjour pouvez vous me dire quel est le bloc de fonction en bas à gauche en sortant de la boucle sur cette aide :

http://digital.ni.com/public.nsf/allkb/589BE1E163AA088C862576AF005D13A7

merci d'avance

Message 8 sur 32
665 Visites

Re: Problème temps labview

Tu parles de la fonciton "Get date/time in second " ?

Tu trouves cette fonction dans la catégorie horodatage.

“En science, la phrase la plus excitante que l'on peut entendre, celle qui annonce des nouvelles découvertes, ce n'est pas "Eureka" mais c'est "drôle"
Isaac ASIMOV
0 Compliments
Message 9 sur 32
662 Visites
Highlighted

Re: Problème temps labview

J'ai pris le temps de regarder le début de la conversation, et j'ai modifié ton VI en conséquence.

Regarde si cela répond à ton besoin.

Bon courage.

“En science, la phrase la plus excitante que l'on peut entendre, celle qui annonce des nouvelles découvertes, ce n'est pas "Eureka" mais c'est "drôle"
Isaac ASIMOV
0 Compliments
Message 10 sur 32
659 Visites