Discussions au sujet de NI LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LV2011 : la résolution de conflit ne fonctionne pas, je deviens fou !!!!

Solved!
Go to solution
Highlighted

Bonjour,

 

je suis sous Labview 2011 64 bits sous Windows 7

 

J'ai un projet que je dois compiler pour créer un exécutable puis un installer.

Au départ dans le projet, j'avais une librairie dynamque.

 

j'ai un problème de conflit, voir photo jointe.

si je résoud le conflit avec Load with Selected, que je sauvegarde mon vi et projet, ça ne fait rien, j'ai toujours le conflit.

 

j'ai tenté de prendre mon projet, de la passer sur une machine avec XP 32bits avec LV2011 32 bits, et c'est pareil

 

il faut absolument que j'arrive à résoudre se problème rapidement, à l'aide c'est urgent

 

 

Merci

 

0 Kudos
Message 1 of 6
(2,509 Views)
Highlighted

Bonjour,

 

Essaie d'ouvrir directement Group1_read_data.vi, effectue la résolution du conflit à l'ouverture et sauvegarde le VI.

 

En général il faut ouvrir directement les VIs affectés par les conflits, les sauvegarder, plutôt que de passer par la résolution des conflits directement dans le projet.

 

Cordialement,

Da Helmut
Voir le profil de Maxime M. sur LinkedIn - View Maxime M.'s profile on LinkedIn
Message 2 of 6
(2,500 Views)
Highlighted

Bonjour,

 

c'est ce que je viens de faire, et ça a fonctionné avec tous mes vi, sauf avec les vi propre à une dll : vi appelant une dll

 

j'ai réouvert mon programme principal qui m'a averti sur les prolèmes non résolus ci-dessus.

Bref, je ne comprend rien, mais je vais retener une compilation...
après une nouvelle tentative de compilation, ça ne marche pas....

 

 

la folie....

 

 

0 Kudos
Message 3 of 6
(2,489 Views)
Highlighted
Solution
Accepted by topic author Minikisscool

Je n'ai pas réussi à éditer le précédent message, alors je fais une réponse.

 

j'ai réussi à résoudre mon problème sans réellement trop savoir comment, si ce n'est que dans mon projet, j'avais un dossier 'old version' dans lequel le plaçait des versions précédente de mon programme.

j'ai supprimé ce dossier de mon projet, et sur mon disque dur, j'ai zippé ces fichiers

depuis la résolution de conflits a fonctionné.

 

Le principal est que ça fonctionne, je pourquoi restera une question....

0 Kudos
Message 4 of 6
(2,478 Views)
Highlighted

Bonsoir, les vi’s « old » de l’ancienne version avaient le même nom que ceux de la dernière version ? mais dans un dossier différent, le dossier « old » était dans le projet ? S’ils ne sont pas dans un dossier « privé », vous ne pouvez pas avoir plusieurs vi’s avec le même nom, cela créera des conflits. Donc pas forcement surprenant.

Message 5 of 6
(2,466 Views)
Highlighted

Bonjour,

 

les fichiers qui se trouvaient dans le dossiers old n'ont pas le même nom

"mon programme 4.0.vi"

et dans le dossier old, j'avais "mon programme 3.9.vi"

 

tout ceci restera donc un mystère, mais le principal est que ça fonctionne, je peux compiler et créer mon programme d'installation, le principal est là.

0 Kudos
Message 6 of 6
(2,455 Views)