Discussions au sujet de NI LabVIEW

annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 

Espec RS485 Erreur 0 : GPIB driver

Résolu !
Accéder à la solution

Bonjour tout le monde 

 

Actuellement, je travaille sur une étuve du fabricant ESPEC:  EHS 221MD pour des tests de fiabilité HAST.

Mon objectif est de communiquer avec l'étuve pour récuperer certaines données  ( temperature, humidité...) et lancer / arreter les essaies. 

L'étuve fonctionne en RS485.

 

J'ai obtenue le manuel de communication de la part du fabricant avec les codes a envoyer pour communiquer avec l'étuve mais a chaque fois que je lance mon VI j'ai cette erreur : 

 

Lcz38_0-1628238366076.png

Je n'ai pas spécialement compris a quoi cette erreur est due, un probleme de driver (pourquoi celui du GPIB) ? ou bien un problème avec mon convertisseur RS485-USB ( Max le détecte pourtant !) 

 

Comme convertisseur j'utilise un  MOXA Uport 1100, cabler en RS485 4 fils,j'ai réaliser le cablage ci contre : 

 

Lcz38_1-1628238366082.png

 

Est ce que vous auriez des solutions a proposer ? 

 

Merci d'avance pour vos réponse, 

 

Cordialement 

 

Lucas 

 
 
Tout télécharger
0 Compliments
Message 1 sur 6
283 Visites

Le standard IEEE-488.2 implémente également les commandes de base scpi telles *IDN?, *RST, *CLR, ... Comme le message semble indiquer que le driver NI-488.2 est manquant (même si ton instrument n'utilise pas un bus GPIB il est possible qu'il utilise le protocole) le plus simple serait d'installer ce driver et voir si ça règle le problème.

 

Ben64

0 Compliments
Message 2 sur 6
242 Visites

Bonjour Ben,

 

Le driver était déjà installer. 

Lcz38_0-1628495734654.png

J'ai essayer de le désinstaller puis de le réinstaller mais rien ne change.

Je pense prendre du coup un convertisseur RS485-GPIB:  https://www.ni.com/fr-fr/support/model.gpib-rs485.html mais les 700 $  me font un peux hésiter.

 

0 Compliments
Message 3 sur 6
231 Visites

 

Attention, le code erreur 0 peut provenir d'une erreur que tu as générées toi-même...

 

Pour preuve : 

Walker34_0-1628511866326.png

 

 

0 Compliments
Message 4 sur 6
218 Visites
Solution
Accepté par l'auteur du sujet Lcz38

@Walker34  a écrit :

 

Attention, le code erreur 0 peut provenir d'une erreur que tu as générées toi-même...

 

Pour preuve : 

Walker34_0-1628511866326.png

 

 


@Walker34, En effet je viens d'ouvrir le code sur un pc qui a la version 20 et il y a une constante d'erreur avec un booléen à T dans le vi.

 

@Lcz38, enlève cette constante à l'entrée de ton vi et tu n'auras plus d'erreur. Additionnellement tu utilises un caractère de terminaison pour ta communication série alors tu ne devrais pas utiliser Bytes at port mais une constante d'une valeur supérieure au message le plus grand que tu t'attends à recevoir (en général j'utilise 1024 sauf pour le transfert de grande quantité de data, par exemple transfert d'image d'oscilloscope). Ainsi le VISA Read s'arrêtera losqu'une des 3 conditions suivantes se produira: 1- caractère de terminaison reçu, 2- nombre de bytes reçus égal à la valeur de la constante, 3- VISA timeout.

 

Ben64

0 Compliments
Message 5 sur 6
210 Visites

@ben64 , @Walker34,

 

Merci pour vôtre aide, tout fonctionne ! 🙂

0 Compliments
Message 6 sur 6
197 Visites