Discussions au sujet de NI LabVIEW

annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 

Connexion ModBus TCP & SCPI

Résolu !
Accéder à la solution

Bonjour,

Je débute sur labview et j'essaye d'établir une connexion entre labview et une alimentation élèctrique.

 

La connexion se fait en ModBus TCP/IP et les requêtes sur la notice sont dans un language "SCPI".

 

J'ai pris la bibliotheque ModBUS et là je me retrouve bloqué car je ne sais pas du tout comment venir faire mes requêtes dans labview.

 

Pour info la notice est en PJ

 

J'ai juste mis dans mon VI un bloc "New TCP Master" avec l'adresse IP, le timeout, le port (8462) et c'est tout.

Est-ce que vous pourriez m'aider, mon niveau est assez faible sur ce logiciel mais il y a un début à tout ! Si il y a une doc expliquant comment établir une communication de ce type je suis preneur (mes recherches ont été infructueuses pour l'instant)

 

Merci d'avance,

 

Arthur

0 Compliments
Message 1 sur 3
192 Visites
Solution
Accepté par l'auteur du sujet SDELTY

Hello

 

D'après la documentation de l'appareil, il n'est pas question de modbus. Essaie plutôt une communication en TCP simple.

 

L'exemple ci-joint devrait te permettre de definir le voltage. Pas sûr que ça marche..

0 Compliments
Message 2 sur 3
163 Visites

Ne pas oublier de remplacer <sp> par un espace et <term> par le caractère de terminaison (la documentation précise le linefeed pas défaut.

 

Ben64

0 Compliments
Message 3 sur 3
146 Visites