Discusiones sobre Productos NI

cancel
Showing results for 
Search instead for 
Did you mean: 

lectura de valores

Solved!
Go to solution

Hola,

 

Estoy tomando unas medidas en LabVIEW mediante el DAQ Assistant. Un USB-6008 está conectado a una tarjeta NMA en una MICRA M, conectada a su vez a un torquímetro que mide valores de par. De la tarjeta NMA sale una señal 4-20 mA. El problema es que al graficar los datos, LabVIEW solo lee los valores de fuerza de signo positivo. Alguien sabe cuál podría ser el problema y como se podría solucionar para obtener también los valores negativos?

 

Muchas gracias

0 Kudos
Message 1 of 7
(136 Views)

Hi,

 

Como configurate la DAQ? Estás usando VIexpress o la API de DAQ? Puedes subir el VI que usas para las medidas? Es un poco dificil encontrar errores sin tener el código original.

 

-Andrés

---------------------------------------------------

Projektingenieur
Restbust, Simulations and HiL development
Custom Device Developer
0 Kudos
Message 2 of 7
(128 Views)

Hola,

 

Adjunto aquí dos imágenes.

 

Annotation 2021-03-22 130929.jpgAnnotation 2021-03-22 131137.jpg

Gracias

0 Kudos
Message 3 of 7
(117 Views)

Hey,

 

Primero: Pon un delay en el el While-loop, no es aconsejable tener un while-loop así, en tu caso la medida misma debería ser suficiente para evitar problemas, pero mejor estar seguros. 1ms deberia bastar.

 

Después: Puedes intentar graficar los datos puros que salen del asistente y ver si los datos están ahí? Y una foto del los datos que salen actualemente en el indicador también sería útil.

 

 

---------------------------------------------------

Projektingenieur
Restbust, Simulations and HiL development
Custom Device Developer
0 Kudos
Message 4 of 7
(102 Views)

Hola,

 

En la primera foto la gráfica da los valores adecuados, que es cuando estoy haciendo un par positivo.

 

El problema está cuando el par es negativo (segunda foto), no reconoce los datos y se queda en 0.

 

Saludos

 

598E22E9-4373-4D76-9488-D9FA86379B96.jpeg

0FB70238-C3DF-4494-8900-10B16F083C64.jpeg

0 Kudos
Message 5 of 7
(53 Views)
Solution
Accepted by topic author martin365

Puedes subir el VI aquí?

 

Que valores de los 4-20 mA corresponden a los valores negativos?

---------------------------------------------------

Projektingenieur
Restbust, Simulations and HiL development
Custom Device Developer
0 Kudos
Message 6 of 7
(42 Views)

Ya lo he solucionado. El problema era que el valor 0 en el display correspondía con el valor 4 mA, por lo que no me media por debajo de eso. 

 

Muchas gracias!!

0 Kudos
Message 7 of 7
(38 Views)