Discusiones sobre Productos NI

cancel
Showing results for 
Search instead for 
Did you mean: 

Limpiar buffer IMAQ_create

Buenos días,

 

He estado revisando ambas y, aunque en una fluctua un poco, no parece significativo. Estos resultados serían válidos si no hubiera que deshabilitar nada ya que el incremento de memoria no es significativo. Es importante que me puedas enviar estos resultados con todo habilitado, de manera que si fuera necesario pudiera reportarlo a ver si me pueden dar una solución adicional. 

 

Lo que me comentas de hacerlo desde fuente, no lo he realizado por que no puedo comprobarlo en el Task manager.

La prueba desde fuente, entendiendo que eso es sin un ejecutable, ¿estamos de acuerdo en que esa es la forma de verlo en el Task manager? Quizás ha habido alguna confusión. Es simplemente para comprobar que ahí, a pesar de no tener la función "unflatten from String" deshabilitada, no te incrementa la memoria. ¿Puedes hacer ambas pruebas? 

 

Ya me dirás !

 

Cristina

0 Kudos
Message 21 of 31
(1,793 Views)

Hola Cristina,

 

Te adjunto los mismos resultados teniendo todo habilitado ("Todo Activado.zip").

Como puedes apreciar en este caso la memoria si va incrementándose.

Lo que he apreciado, es que obtengo un error al meter en el "unflaten from String" la cadena vacía (Error 74 "Unflatten From String in Host.vi").

 

Te envío también, los mismos resultados pero sin enviar la cadena vacía, lo deshabilito ("Sting deshabilitada.phg") para que veas el incremento en este caso mayor. ("Todo activado sin String.zip")

 

Lo de hacerlo desde fuente, me refiero a que como no tengo ejecutable (Application.exe), no puedo ver su consumo de memoria en el Windows Task-Manager, ya que no aparece. Cómo podría comprobar el consumo en este caso??

 

Un saludo y muchas gracias!!

0 Kudos
Message 22 of 31
(1,784 Views)

Lo he ejecutado desde fuente, sin ejecutable, y te envío resultados en el Windows Task-Manager.

 

Gracias por tu tiempo!!!!

0 Kudos
Message 23 of 31
(1,779 Views)

Hola,

 

Siento la tardanza, lo primero, el error 74 es porque estás metiendo a la función un string que no está en formato binario. 

 

http://forums.ni.com/t5/NI-Applications-Engineers/Error-74-at-Unflatten-to-String-on-LV-2010/td-p/12...

 

Por otro lado, de las capturas me sorprende que en el Task manager si suba pero en LV apenas cambie. prueba a resolver lo del error 74, si lo consigues y sigue el mismo problema puedo intentar reportarlo pero es raro que me den una respuesta distinta a ese workarround. 

 

Nada, pensé que no ejecutabas desde fuente por los pantallazos, pero lo estamos haciendo igual.

 

Ya me dirás,

 

Cristina

0 Kudos
Message 24 of 31
(1,766 Views)

Hola Cristina,

 

Gracias por la respuesta.

El link que me envías no puedo acceder a él.

 

Por otro lado he intentado resolver el error (te adjunto), pero me sigue dando el codigo 74 continuamente.

Alguna idea por favor de como resolverlo?

 

Un saludo y muchas gracias!!

0 Kudos
Message 25 of 31
(1,761 Views)

Hola,

 

Del foro sólo nos interesaba esta parte :

 

Error 74 will occur when using the Unflatten from String function with a string input that's not flattened (not in binary format).  Looking at this VI, I don't understand why the customer is using the Unflatten from String function as the custom data should be returned as a normal string.  It looks like he wants the Fract/Exp String to Number function to convert from a string to a number.

 

 

No obstante, hay una manera, no muy elegante pero podría valer de hacerlo. Al final es un paso intermedio sólo para intentar reducir el uso de memoria. ¿Puedes probarlo?

0 Kudos
Message 26 of 31
(1,748 Views)

Hola Cristina,

 

Perdona por la tardanza.

No sé si te he entendido correctamente, pero he anadido el "Flatten To String" como me indicas en tu ejemplo.

(Host.png)

 

Lo he comprobado y te adjunto de nuevo pantallazos. No obtengo error, pero sigue el consumo de memoria.

 

 

Un saludo y muchísimas gracias!!!

 

 

0 Kudos
Message 27 of 31
(1,737 Views)

Hola,

 

Vale si con esto no se arregla es porque hay algo en el software que está funcionando de manera distinta a la esperada. ¿Es posible reinstalarlo? Si lo fuera sería perfecto; en caso de que eso tampoco funcionara lo reportaría pero no sé cuanto pueden tardar en arreglarlo. 

 

Vamos viendo. Un saludo,

 

Cristina

0 Kudos
Message 28 of 31
(1,719 Views)

Hola Cristina,

 

Gracias por la ayuda, pero no creo que reinstalando el software completo me ayude mucho, ya que tengo el mismo problema tanto en LV2013 como usando LV2014, no??

 

 

Un saludo y muchísimas gracias de nuevo.

0 Kudos
Message 29 of 31
(1,713 Views)

Hola,

 

Perdona la tardanza,si yo pensé en eso pero entonces no entiendo por qué a mi con las 2014 no me incrementa la memoria. Entiendo que si fuera algo de la versión el mío también se incrementaría, ¿no es así?

 

Un saludo

0 Kudos
Message 30 of 31
(1,696 Views)