Digital Multimeters (DMMs) and Precision DC Sources

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI-4070 measures AC voltage incorrectly without AutoZero

When I use the NI-DMM Softfrontpanel with my PXI-4070 DMM I get strange measurement results.

Input Signal: 4.024 Vdc + 0.101 Vacrms

PXI-4070 Configuration:
- NI-DMM Driver: 2.0.1
- Range: 50 V
- Resolution: 6.5 digits

According to the above settings the PXI-4070 should have a resolution of 0.1mV.

If I measure the signal with AutoZero I get the correct reading of 0.1013 Volts.
But if I disable AutoZero I get the incorrect reading of 0.0968 Volts.

I'm a little bit astonished that I cannot take correct AC Voltage readings without Autozero with a 6.5 digit DMM. Even more curious is that the NI-DMM driver's measurement defaults are set to AutoZero = Off for all AC-Voltage readings.

So am I doin
g something wrong or is something wrong with my PXI-4070?

BTW I tried this with two PXI-4070 devices (SN: D402F2 & D4254A) and both show the same sympthom.

Kind Regards
Herbert
*********************************
Herbert Koltschik
Sagem Communication Austria
herbert.koltschik@sagem.com
*********************************
0 Kudos
Message 1 of 3
(5,164 Views)
Herbert,
Let me reassure you that both of your 4070s behave as expected.

You can only apply the AC accuracy specification table if you are in 6 1/2 digits of resolution, your signal is greater than 1% of range and Autozero is enabled.

In your case, the range is 50V and a signal of 0.101V is below 1% of the range. The AC accuracy table is no longer applicable and the resolution will not be 100uV.
You should probably choose a smaller range such as 5V of even 500mV.

Autozero is necessary to achieve the highest resolution. In your experiment, when you disable it, you cannot accurately read your input signal: 0.0968V. When you enable it, you increase your resolution and your reading is correct. You should try lowering the range to 500mV and see if you can correc
tly read your input signal without AZ.

NIDMM 2.0 do not optimize AC measurements for the highest resolution like in DC measurements. If you require a resolution higher than the one given without autozero, you can enable autozero.

Good luck.
0 Kudos
Message 2 of 3
(5,164 Views)
GF,
thank you for your prompt response.
Your explanation sounds logical.

Maybe you can help me with a related question I've posted recently:
http://exchange.ni.com/servlet/Redirect?id=8777429

Thanks!
Herbert
0 Kudos
Message 3 of 3
(5,164 Views)