Digital Multimeters (DMMs) and Precision DC Sources

Showing results for 
Search instead for 
Did you mean: 

PCIe-4065 Intermittent error -1074118650

Hi Folks,

First time, long time. I've been running a PCIe-4065 DMM on a machine for months now, running the same program just fine, until recently it started hitting me with:

"Error -1074118650 occurred at niDMM An error was returned by one of the internal function calls. An internal error has occurred."

We use just one instance of this VI, and it is used for both a voltage read and a 4-wire resistance read. Interestingly, the error has so far only occurred during the resistance read. It doesn't occur every time and is so far unpredictable. I tried updating NI DMM to 18.5, still happens. I checked the fuse on the board, all good. A search doesn't reveal much about this error. Any insight on what might be causing this?


Matt Payne 

0 Kudos
Message 1 of 5

Edit: I spoke too soon. The error now occurs during voltage reads as well.

0 Kudos
Message 2 of 5

The same error code returned a different description this morning:

"The specified operation cannot be performed because a task has been aborted or a device has been removed from the system. Handle this situation as required by the application and then, if appropriate, attempt to perform the operation again."

We are suspecting a PC hardware issue. We tried another 4065 card from an inactive machine and are still getting the same error. 

0 Kudos
Message 3 of 5

Hi Matt, do you get similar errors when running any of our DMM shipping examples? This will help us isolate the problem to either software or hardware.

Lindsey Nestor
Program Manager, Hardware Services
National Instruments
0 Kudos
Message 4 of 5

Hi Lindsey, and thank you for the reply! We haven't tried that yet. We replaced the PC with another of almost identical build, moving all software and NI hardware to the new PC. So far so good. That machine is in high demand, but if I get a chance I will test out the old PC with those programs for science's sake. I'll update at that point because this error doesn't seem to be common or well known, but for now it certainly seems like the error is a hardware error considering that the error arose out of nowhere after months of smooth sailing, and especially since changing the PC has thus far solved the issue.

Message 5 of 5