Digital Multimeters (DMMs) and Precision DC Sources

Showing results for 
Search instead for 
Did you mean: 

DMM PXI-4070 Internal Hardware Error - 1074117756.000000

restructure code so that the dmm doesn't have to think.  use other lv blocks to do analysis or result detection. 

0 Kudos
Message 31 of 36



There is a way to use an older version of LabVIEW with a newer version of NI-DMM which does not technically support it. Before upgrading, copy the following files/directories from your LabVIEW 7.1 folder to another folder (assuming you installed to C:\Program Files\National Instruments\LabVIEW 7.1):

C:\Program Files\National Instruments\LabVIEW 7.1\examples\instr\niDMM

C:\Program Files\National Instruments\LabVIEW 8.5\instr.lib\niDMM


After installing the newer version of NI-DMM, copy your backed up files into their original locations.

I believe those are the only two folders you will need to back up in order to use NI-DMM. If you also use ModInst, you will also need to back up instr.lib\niModInst and niModInst.ctl, .rc, and .rch from resource\objmgr. If you want to be extra safe before upgrading, back up your entire LabVIEW 7.1 directory. Once you upgrade, copy the files I mentioned back to the original, and if there are files that I forgot to mention, you can then copy those back as well.


Please let us know how this works for you.


Thank you, and good luck!


-Tobias G

Software Engineer

Precision DC Group

National Instruments

Principal Software Engineer
Driver Software
National Instruments
0 Kudos
Message 32 of 36

I have an DMM PCI-4070 and I received same Error as ERROR: -1074117756 Internal Hardware Error

I have installed Lab View 2009 and DMM driver 3.0.2

Some body found an work arround for this error ?


Thank You

Alexandru Nan

0 Kudos
Message 33 of 36

Hello Alexandru,


Are you performing frequency measurements using autoranging as discussed in the previous posts? 






National Instruments
0 Kudos
Message 34 of 36

No, I'm trying to open the DMM application and give me this error, and if I try self-test from MAX it give me the error: -233905. I have checked the F1 fuse and is OK. I have installed and the last driver from NI DMM 3.0.6 and same result.

0 Kudos
Message 35 of 36

I have managed to determin from what was that error ! It seems to be about the PCI interface first I try to connect to an old asus mother board p4i45gv with an old chipset (intel 845) that suports P4 processors on soket 478. And received the error message ! After replaceing the MB with an Intel D946GZIS and reinstalling the labview and the card it seems now it's working fine !

This make me to take a conclusion it depends on the chipset of the board and ca be a difrent interface of the PCI. I observed a difference about this when the PCI-4070 was istalled on the asus board a red led was lighting(on) after i put on the intel board that led goes off !



0 Kudos
Message 36 of 36