Digital I/O

Showing results for 
Search instead for 
Did you mean: 

installation of ni-daqmx-runtime-core using NI Package Manager 23.0.0

Go to solution

I'm facing a problem running the installation of ni-daqmx-runtime-core using the following batch script which is run as administrator:

start /wait NIPackageManager23.0.0.exe --prevent-reboot
"c:\Program Files\National Instruments\NI Package Manager\nipkg.exe" install ni-daqmx-runtime-core --accept-eulas -y


It works fine on my virtual machine, but is does NOT work on my local machine, stating the following error message "Unable to locate package 'ni-daqmx-runtime-core' with a compatible version and architecture". Both machines are 64 bit system and use Windows 10, version 22H2. I already tried to specify the package version to  ni-daqmx-runtime-core_23.0.0.49366-0+f214_windows_x64 (using the following line "install ni-daqmx-runtime-core:windows_x64_23.0.0.49366-0+f214"), but it did not solve the problem. Additionaly I tried using PackageManager version 23.3.0, but this also did not work out.

I would be pleased to receive any help.

0 Kudos
Message 1 of 4

Problem occurs only when using an online installation, using a local package feed works. When going to the online feed's url there are no packages found. Anyone an idea whether the package url has changed or some other advice.

0 Kudos
Message 2 of 4
Accepted by topic author alfdghoadhsfglnkafl

Rafael, when you are trying to use "online feed", I assume you are trying to connect to a feed, and if so, did you register an feed that has that package?



nipkg.exe feed-add --name=mydaquri


nipkg.exe update

Scott Richardson
0 Kudos
Message 3 of 4

Hi Scott,


I very much appreciate your advice, it helped me to resolve the issue.

Best regards



0 Kudos
Message 4 of 4