Digital I/O

Showing results for 
Search instead for 
Did you mean: 

can't find file nidaq32.dll

I have an application that uses 2, PCI-DIO-96 boards writen in Visual Basic 6.0.

When I run the application on the target machine as an administrator, I have no problems.

When I run the application on the target machine as the user "operator", as a member of the Users group, I get error 48, "can not find the file C:\Windows\system32\nidaq32.dll".  The file exists and has the "Read & Execute" and "Read" permissions set.

Do I have to promote the user to a higher level group, or is there something else that I can do to get it to run?  I would like to give the user "operator" the lowest priviledge possible.
0 Kudos
Message 1 of 7

The first thing that you should try is to upgrade to the newest version of the Traditional DAQ driver.  Some older versions of the Traditional DAQ driver ran into some permission issues but the 7.4.1 driver works much better.  To download this free upgrade for Windows 2000/XP just follow this link.

If you have already upgraded to the 7.4.1 driver and you are still experiencing problems please let me know and we can try a few other things.

Have a great day,

Brian P.
Applications Engineer
0 Kudos
Message 2 of 7
From Automation Explorer (?), current NIDAQ version is 7.4.1f4.  This appears to be the same version in the download link, so....

I still have the problem.
0 Kudos
Message 3 of 7
There is another discussion forum that addresses the same issue so you might look at it and try the steps that it suggests.  You can find the other post here.  Hopefully the solution posted at this link will help solve you issue as it has with other users.  If you continue to have problems can you please let me know a few more details:

Do you have DAQmx installed as well and if so what version? 
What OS are you using?
What permissions are allowed for the system32 folder?

Have a good day,
Brian P.
0 Kudos
Message 4 of 7

re: download link provided above


"The Drivers and Updates entry that you requested is currently unavailable. Please look for a similar entry in the All Versions view , or contact National Instruments Technical Support for assistance. "


Checking "All Versions" I get error 404 for any product line, software, software version I can think of.

0 Kudos
Message 5 of 7
The link to the 7.4.1 driver works for me. The other link seems to be broken but you can click the 'Support' link at the top of the page and then Drivers and Updates link on that page to take you to whatever driver you want.
0 Kudos
Message 6 of 7



Here is a link to the newest version of Traditional DAQ ( does this work for you?  If not what browser are you using?

Jason Daming
Applications Engineer
National Instruments
0 Kudos
Message 7 of 7