Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

USB DAQ 6001 - No Devices Found

Solved!
Go to solution

I use USB DAQ type 6001 for Multi Input Output to control 3 phase Induction Motor through inverter. After some time running (around 8 months), somehow "No NI Device Found" in NI Device Monitor. When I looked at NI Hardware Configuration, it show "Software Not Installed". In fact, all of my software is already up to date.
When I looked the hardware, It is okay. The lamp indicator works (to show it is on or not).

 

Is there anyone know how to solve this problem?
Which one the problem? hardware or software?

Thank You

0 Kudos
Message 1 of 10
(462 Views)

Hello there,

 

It seems to me there might be a software issue. I suggest you reinstall the drivers and software and try reconnecting your device. There are also a few articles that could be helpful when you don't see your device in NI MAX:

Error -88705 When DAQ Device Is Not Detected in NI MAX - NI

NI DAQ Device or Module Does Not Appear in LabVIEW And/Or MAX - NI

 

Update me on what's going on after you reinstall the software.

0 Kudos
Message 2 of 10
(428 Views)

Thank You for the response.

I have already done it. It does not work. It is still error like before, nothing change.

0 Kudos
Message 3 of 10
(418 Views)

Do you have any other idea?
I have tried your solution many times anyway. Thanks

0 Kudos
Message 4 of 10
(396 Views)

Hello again,

 

Please tell me where the Hardware Configuration screenshot is from. It seems to me that the interface doesn't look like NI MAX.

If you have any error messages pictured, I'd like to see them as well.

If you already reinstalled your drivers, I could only suggest checking if the cable connecting the hardware to the system is intact. After all these steps, if you still cannot get your system to recognize the hardware, I recommend reaching out to NI Support.

 

Let me know if I can help you with anything else.

0 Kudos
Message 5 of 10
(378 Views)

hello, thank you for the response.

All cable are in intact. I have made sure it many times
It is actually from NI MAX (NI Device Monitor = shows that no NI Device Detected) (NI Hardware Configuration Utility = shows error "No Software Installed")
I already have my Ni DAQMX installed (already reinstall it many times)
Ni MAX also shows no device detected (already refreshed it many times too)
The errors never solved and changed.


Here we go the some pictures 

Download All
0 Kudos
Message 6 of 10
(369 Views)
Solution
Accepted by topic author ChrisVier\

Thank you for attaching the whole screenshots.

What I suggest is to troubleshoot hardware installation following this link:

Troubleshooting Hardware Installation Problems - NI

 

You can also check this article to repair your software in NI Package Manager (NIPM):

Troubleshooting Hardware Installation Problems - NI

As we don't know if it's a software or hardware issue, make sure to go through all the steps described in the articles and let me know if anything worked for you.

I also wanted to clarify one thing. You said that the device suddenly stopped being recognized after 8 months of operation. Can you remember if something changed at that time? Maybe you had a new update installed on your system, or there was an abrupt voltage change in the building. Let me know if you suspect anything, even if it seems insignificant it can help us dig in the right direction to find the solution to this issue.


0 Kudos
Message 7 of 10
(356 Views)

Hello, sorry for the very late response

I have followed the instruction and it is work. Now the NI-USB 6001 work properly and nothing error anymore.

Thank You so much

0 Kudos
Message 8 of 10
(270 Views)

Hi again,

 

Glad to hear that!
Can you tell me what exactly worked for you? I'll note it as a solution for future.

Also, feel free to mark my reply as a solution so people with a similar issue can use it as a reference.

0 Kudos
Message 9 of 10
(265 Views)

What I did is based on the link that you share. This link
Troubleshooting Hardware Installation Problems - NI

The issue is "INSTALLATION ORDER" and not register the device yet (after reinstall since 2 months ago)

 

This is what i do:
1. Uninstall all NI Software
2. Uninstall and remove all NI Device (disconnect everything)
3. Install back the Software 
4. It will need to reboot your PC
5. After reboot, shut down it, then install back your hardware. When it done, turn it on.
6. Then, open NI Registration Wizard. Log in to your NI account, and register your device through serial number of your Device.

Follow the order, then it will solved

Thanks

Message 10 of 10
(258 Views)