Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

USB 8451 - can not use SPI - device is recognized by DAQmx as IO port only

Solved!
Go to solution

Hallo,

 

I have a problem with an 8451 SPI interface. It is connected to my system (labview 2019) and is recognized by the Measurement and Automation explorer - but then only for use of the digital I/O ports.

 

When trying to use the dedicated 845x drivers with SPI support in my labview program, no device is found.

 

How can I make sure that the device is available for the dedicated driver and not claimed by DAQmx?

(DAQmx is required for another instrument).

 

0 Kudos
Message 1 of 6
(189 Views)

It seems unlikely that DAQmx will claim an 845x device as DAQmx does not even support the 845x device. Could you post screenshots of the issue you're facing?

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF
0 Kudos
Message 2 of 6
(166 Views)

Drivers can be found here for the 8451:

https://www.ni.com/en-us/support/downloads/drivers/download.ni-845x-driver-software.html#428064

 

-AK2DM

~~~~~~~~~~~~~~~~~~~~~~~~~~
"It’s the questions that drive us.”
~~~~~~~~~~~~~~~~~~~~~~~~~~
0 Kudos
Message 3 of 6
(159 Views)

Hi all, thank you all for the replies.

 

The 845x driver is installed, this is not the problem. However, the device is claimed by a driver called "USB-6501". I do not have a photo of the device to share today (home office with remote connection), but it is clearly labelled outside USB-8451.

 

Below are some screenshots: NI package manager, windows device manager, measurement and automation explorer, 845x in labview, the probem with the device not being present.

Screenshot 2022-05-06 at 09.14.30.pngScreenshot 2022-05-06 at 09.16.53.png

Screenshot 2022-05-06 at 09.05.45.pngScreenshot 2022-05-06 at 09.07.40.pngScreenshot 2022-05-06 at 09.08.46.png

0 Kudos
Message 4 of 6
(136 Views)
Solution
Accepted by crossrulz

Are you sure it is an 8451? it definitely looks like a USB-6501

 

Both 8451 and 6501 use similar enclosures and connectors (maybe the same) and it could be mistaken for the other.

santo_13_0-1651849325234.png

 

santo_13_3-1651849405395.png

 

 

 

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF
Message 5 of 6
(123 Views)

After checking again it turned out that my device really is a 6501 which was mounted in a 8451 enclosure. Quite confusing...

Thank you all for your valuable help.

 

0 Kudos
Message 6 of 6
(108 Views)