Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

NI USB-6009 is not reading values

I am having some DAQ issues. I am using the NI USB-6009 to read bits sent from an external decoder/counter to give me motor RPM. I interfaced a PIC microcontroller to tell the decoder and LabVIEW when to run. So my DAQ is watching my microcontroller and telling it when to run and take bits of data from my decoder. My code and readings were working fine the other night, and when I came back the next morning, my DAQ was not reading these values anymore and saying that every input is actually high in Labview. I have connected LED's to my PIC to ensure that the program is working, and the LED's are blinking in an on/off state so I know that it is not the program and that it is sending both a high and a low state to the DAQ. But the DAQ is not interprutting this. I have attached my .vi just incase it is of some assistance. I have also gone into the MAX and reset the DAQ and did a self test to ensure everything was okay. Thanks for the help.

 

-Nick

0 Kudos
Message 1 of 3
(2,098 Views)

Hi archimedes_s14

 

I would start by verifying that the 6009 is seeing the signal. You can open a Test Panel through Measurement & Automation Explorer and see what is currently being input to the DAQ device. If you are not seeing the signal in the Test Panel I would check to make sure your conection on that chanel is secure. Post back with what you find using the Test Panel.

 

<Brian A | Applications Engineering | National Instruments> 

0 Kudos
Message 2 of 3
(2,065 Views)

I actually found out that the USB-6009 has pull-up resisors and my output was tri-state on my IC. Therefore, all inputs went high when not grounded properly. Thanks.

0 Kudos
Message 3 of 3
(2,029 Views)