Digital I/O

Showing results for 
Search instead for 
Did you mean: 

Get_DAQ_Device_Info and PXI-6508 problem

I have a PXI-6508 (among others) in a PXI chasis. The Measurement & Automation Explorer detects it with traditional NIDAQ as device 6.


I am using traditional NIDAQ in my application.


Using Init_DA_Brds(6, &code) works fine and returns the correct code (240) for the device.


Using Get_DAQ_Device_Info(6, ND_DEVICE_TYPE_CODE, &info) does not work as expected, and returns 0.


Is this fixable?


Note: Get_DAQ_Device_Info seems to work fine for all my other devices (6052E, 6040E, 6602 (I have 3 of those), 6733, 6533).



Gil Rivlis OR

0 Kudos
Message 1 of 6

I forgot to mention:


the Get_DAQ_Device_Info call returned error -10461 (The specified resource is unavailable because it has already been reserved by another entity.).

it works on the other devices without error;


even calling Init_DA_Brds before calling  Get_DAQ_Device_Info does not fix the error.



0 Kudos
Message 2 of 6

Hi Gil,

         There doesn't seem to be a whole lot of documentation on the error you're getting, but I'll try to help the best I can.  First, I would try to reset your device in MAX under Devices and Instruments»Traditional NI-DAQ (legacy) devices, by right clicking on your device and selecting "Reset Device".  Then try to re-run your program.  As well, does this hardware work when you run any example programs?  You can find these examples on your computer at: C:\Documents and Settings\All Users\Documents\National Instruments\NI-DAQ\Examples .  Thanks!


Applications Engineer
National Instruments

Digital Multimeters
0 Kudos
Message 3 of 6

I have some more information:


(1) The problem was not with my software. When trying to run the test panels in MAX, I also got the same error code. On the other

hand, running the test panels of the NIDAQmx device worked fine.

(2) I uninstalled DAQmx and the problem went away.


conclusion: NIDAQmx 8.9 broke something.


This is a problem because I also have a M-series device that I use for a different project, and now I can't use it.



0 Kudos
Message 4 of 6
Your device is supported by both traditional DAQ and DAQmx so when you installed DAQmx, you made the default driver DAQmx. You can have both installed and you could have reset the 6508 to use the traditional driver. Ultimately, the best solution would be to drop the obsolete traditional DAQ driver and move to DAQmx if all of your devices are supported by it.
0 Kudos
Message 5 of 6

I don't think this is the problem.


I am well aware of the traditional and mx drivers issues. I have multiple other devices that work with both drivers installed. Just the 6508 doesn't.


I am resetting the device before using, but it still doesn't work.


I don't know what it means 'default driver'. 



0 Kudos
Message 6 of 6