Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

Does the NI 1722 Smart Camera support CIP?

I am trying to communicate between a Logix 5555 and my NI 1772 Smart Camera.  I can not seem to figure out the protocol that is needed for this to happen.  I used a generic ethernet module in RS Logix 5000 software to set up the communication but can't seem to get it right.  I was told that if the camera does not support CIP then I can not use the ethernet to communicate with the PLC.  I would have to use the RS232 port. 

0 Kudos
Message 1 of 5
(2,884 Views)

Hi Swobodatech,

 

There is a driver for LabVIEW posted on NI Labs that adds the ability to communicate with PLCs such as your Logix 5555 controller. The current version of this driver has the ability to do explicit messaging using ControlLogix tags. This will allow your Smart Camera to read and write to global tags you have created within RSLogix5000. Eventually we will be adding the ability to create assemblies on our controllers that you will be able to add into RSLogix (as a remote Ethernet/IP module) as remote I/O.

 

We also have an free add-on to Vision Builder for Automated Inspection 3.6 that adds EtherNet/IP capability (you didn't say if you were using LabVIEW or VBAI to program the Smart Camera).

 

Let me know if this is helpful or if you have any more questions about this support. You might also want to consider posting questions regarding this into the discussion thread for NI Labs EtherNet/IP support or the Machine Vision forum for Smart Camera-related questions.

 

Eric

0 Kudos
Message 2 of 5
(2,865 Views)

I have downloaded the .zip file for the free VBAI 3.6.  When I try to open the file I get a message:

 

Please insert the last disk of the Multi-Volume set and click OK to Continue.

 

What disk is being asked for?

 

 

0 Kudos
Message 3 of 5
(2,848 Views)

Hey,

 

When you say you get the message when you try and open the file, which file do you mean?  The zip file that you downloaded?  The setup.exe file inside the zip file?

 

I downloaded the addon this morning and tested it out, it downloads fine, unzips correctly and installs correctly on my machine.  I'm not sure why it would be asking for another disk anyways.  Could you also post a screenshot of this message box?

 

I would suggest attempting to re-download the patch and using the built-in zip file program in windows.

 

Let me know if you still have the problem after trying the above things.

 

Cheers, 

Evan D.
Installer R&D
National Instruments
0 Kudos
Message 4 of 5
(2,817 Views)

I have re-downloaded the software and it works.  Now I am can't seem to get the "Tags" to be valid.  I have read them from the .l5k file for import but I still get the invalid tag statment.

 

Any information on this?

0 Kudos
Message 5 of 5
(2,794 Views)