Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot read from PCI-6503

Hello,
I want to read an external signal with Port C of a PCI-6503. But all lines of Port C are always on high signal. In the Max - Test Panel all LEDs of the input terminal 2 are red and connecting with external 5V-Signal brings no response. What can I do?
0 Kudos
Message 1 of 4
(2,539 Views)
cosw,

When using the Test Panels in Measurement and Automation Explorer (MAX), the LEDS will probably all be red by default. If you connect a TTL compliant signal to the Digital lines and toggle back and forth between 0 and 5V, then you should see the LEDs turn on and off.

To verify that these lines are working, you may want to try setting them as outputs in the test panel, and use a multimeter to determine if they toggle between 0 and 5V when you change the logic level in the test panel.

If they do not change, and other lines on the board do work, you may want to click on the Support Tab at the top of the screen and choose to 'Phone NI' for additional help, and to discuss the possibility of getting your board repaired if necessary.

Regards,
Jed R.
Ap
plications Engineer
National Instruments
0 Kudos
Message 2 of 4
(2,539 Views)
Thanks for your answer but the problem isn´t writing. Toggling between high and low produce a 5V-Signal, thats correct. But I cannot read an external signal.
If I press the read-button in the test-panel all LEDs become red and there are the appropriate TTL 5V-Signal. But if I toggle with an external 5V-Signal the LEDs don´t change.
0 Kudos
Message 3 of 4
(2,539 Views)
cosw,

You may want to try hooking two of your digital lines together, and then configure one of them as an input and one of them as an output. You can then toggle the output and verify that the input responds. This would allow us to remove the external signal from the equation, and verify that the board is working correctly.

Regards,
Jed R.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 4
(2,539 Views)