DigiMetrix

cancel
Showing results for 
Search instead for 
Did you mean: 

Digimetrix Error: 401865 and Epson RC+ 7.0 Error: 1503

Hello

I tried to run the DigiMetrix example 1 and 2 to check the connection and get the status. The error messages came out. I have checked the cable connection and settings.The errors still came out.

 

The DigiMetrix gave

Error 401865 occurred at Epson Robotics Library

Possible reason(s):

Communication problem detected

 

The RC+7.0 gave

!!Error: 1503, Disconnection while executing a task.

 

When example 2 was executed, the VI showed the controller was in Auto mode ( the green indicator turned ON), and then the errors came out.

 

The Epson guy came and checked. He said the ethernet communication between my PC and RC90 controllers is ok. He cannot do any thing with DigiMetrix software.

I followed the steps and checked the settings on DigiMetrix manuals. The settings are the same as the manual except that the IP is 192.168.0.2

 

Does any one know what the problem is and how to solve it?

Thanks

 

My environment

Windows 10 and 11 ( I tried both of them)

Labview 2020 (20.0f1, 64 bit)

DigiMetrix Epson Robotics Library 3.2.0.84

Epson RC+7.0 (version 7.5.1 )

 

Download All
0 Kudos
Message 1 of 2
(885 Views)

Hello!

The message “!!Error: 1503, Disconnection while executing a task.” is absolutely normal – it just means that DigiMetrix software closes connection by just switching off the communication, you will see this message after every “Close Session” call, it does not affect the functionality.

 

The communication troubles you have run into – it looks like a known issue. The newest controller versions seem to use the port 2000, so, when DigiMetrix library tries to use it, communication errors come up. Please reconfigure to use some other port, 3000/3001. To do so:

-              During controller configuration on step 8 of our manual (System Configuration -> Controller -> TCP/IP -…) set :

o             For port 201 -> port 3000

o             For port 202 -> port 3001

-              For connection setting in LabVIEW for “Open Session” specify “IP1 port” = 3000 and “IP2 port” = 3001

 

Best Regards,

0 Kudos
Message 2 of 2
(847 Views)