Developer Center Discussions

Showing results for 
Search instead for 
Did you mean: 

Why My Addon name is not listed in the Third Party Add-on window

Go to solution

The German version of LabVIEW should not cause any issue.  Unfortunately, the 2011 build of LabVIEW will not have the LV2P debugging statements as they were added in LabVIEW 2012.  Which add-on are you trying to activate?  Do you receive an error when opening an example VI for the add-on?  If so, what error? Can you verify the license file exists for this add-on in the registry and on disk?   Registry for Win7 x64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\National Instruments\LabVIEW\13.0\PartnerAddons  License files: c:\programdata\National Instruments\partners\  In the registry and on disk there will be a folder/token for the partner product.

0 Kudos
Message 11 of 20

We are trying to activate our own library.

If we try to use add-on we get a message: "[Library name] add-on is expired or invalidly licensed".

License exists both on disk and in the registry.

We tried to run "RegisterAddon.exe" as administrator, but it hasn't changed anything.

Log file from RegisterAddon shows that registration was ok.

Any more tips? It's a little bit curcial for us to get it running, otherwise we can not really use the toolkit...

0 Kudos
Message 12 of 20

Do you have a period in the company name registered in your product definition?  If so, please remove it and try to go through the process again.

Could you email your log file and a screen capture of your registry entries to us at


0 Kudos
Message 13 of 20

No, company name does not contain any periods.

I send a log and screenshots to the address provided.

0 Kudos
Message 14 of 20

Hi David and Robert.

A potential customer is in a situation similar to Prithivi's.  Unfortunately, the link that David posted on Aug 1 2012 is no longer valid.  Do you know if the update that David refers to is still available on the MS website?


0 Kudos
Message 15 of 20

Hey John,

I tried to find their root certificates update about 6 months ago and it looks like they removed access to the installer/update they were hosting.  Perhaps it has something to do with phasing out Windows XP/7?

What OS is the customer running?  Do they have access to Windows Updates?


0 Kudos
Message 16 of 20
0 Kudos
Message 17 of 20

Hi Robert.

The customer is currently using Win XP.  They're going to look into using a newer OS.

Thanks for your help.


0 Kudos
Message 18 of 20

@RDR wrote:

Maybe this would work:


0 Kudos
Message 19 of 20


We have a problem similar to discussed here - the add-on we made does not show up in Help->Activate Add-s section.

I have created a separate discussion, because this one is marked as solved.

Please, take a look, any ideas are greatly appreciated.

0 Kudos
Message 20 of 20