Delacor Toolkits Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

[Zuehlke] Project explorer menu for DQMH

Highlighted

Hi Thomas

 

I do not call this file directly, it is called by the DQMH event itself. This means that the correct file is started.

 

Can you start this VI directly from the Explorer?
C:\Program Files (x86)\National Instruments\LabVIEW 2017\project\Delacor\DQMH\Create New DQMH Event.vi

 => I'm calling up this file.

 

Regards
Claude

CLA / CTD
0 Kudos
Message 11 of 35
(1,510 Views)
Highlighted

Hi Claude,

 

i have seen this meanwhile in the vis you mentioned.

 

If i use your menu e.g. at delacors DQMH example it runs with no errors.

I have my source folder mounted as a drive with

"net use v: "\\localhost\c$\Project123\" /PERSISTENT:YES"

 

Could this be a reason?

 

best regards
Thomas

0 Kudos
Message 12 of 35
(1,495 Views)
Highlighted

Hi Claude,

 

i forgot to tell you, that the DQMH Dialog for Create New Event opens normal. But when hitting the OK button to create the event, the error message appears and nothing is created.

 

The other functions are running well - renaming, deleting, validating... only creating fails.

 

 

best regards
Thomas

0 Kudos
Message 13 of 35
(1,493 Views)
Highlighted

Hmm... That's a little weird. Can you copy the same project locally?
We probably have to look into Fabiola's source code!

 

@Fab Can you take a look at this?

 

regards
Claude

CLA / CTD
0 Kudos
Message 14 of 35
(1,491 Views)
Highlighted

I copied my project to c:\temp. 

It is now missing a lot of project dependencies, but that shouldn't matter.

 

AND it throws the same error.

 

Okay found next hint:

Modules based on delacors template doesn't throw an error.

The module throwing the error based on MGI's Panel Manager Framework clonable template.

 

best regards
Thomas

 

0 Kudos
Message 15 of 35
(1,487 Views)
Highlighted

Hi Thomas,

 

Do you get the same error if you start the creation via the Tools>>Delacor>>DQMH menu?

 

Seems like you think this is in one of the MGI Panels modules. What version of the MGI Panels are you using? Are you using DQMH 4.0?

 

Is there a way you can reproduce this issue with a simple project? if not, can you share your code?

 

Thanks,

Fab

I'm Organizing the GLA Summit!


For an opportunity to learn from experienced developers / entrepeneurs (Steve, Joerg, and Brian amongst them):
Check out DSH Pragmatic Software Development Workshop!

DQMH Lead Architect * DQMH Trusted Advisor * Certified LabVIEW Architect * Certified LabVIEW Embedded Developer * Certified Professional Instructor * LabVIEW Champion * Code Janitor

Have you been nice to future you?
0 Kudos
Message 16 of 35
(1,473 Views)
Highlighted

Good morning Fab and Thomas

 

I was able to find the error. The problem was in an incorrect application reference.
You can replace the following file and it works as desired!

 

C:\Program Files (x86)\National Instruments\LabVIEW 2017\project\Delacor\DQMH\_DQMH New Event

 

 

 

regards
Claude

CLA / CTD
Message 17 of 35
(1,466 Views)
Highlighted

Good morning Claude,

 

i can confirm this fixes this issue. Awesome!

 

best regards
Thomas

0 Kudos
Message 18 of 35
(1,463 Views)

I have released a new version for DQMH 4.1. This version contains the new menu structure and the new commands.
The command "Convert DQMH Event" currently generates an error message. The problem is known and Fabiola will surely fix it. 😉

New version, see OP.

 

Greetings
Claude

CLA / CTD
Message 19 of 35
(1,238 Views)
Highlighted

@Fridu wrote:

I have released a new version for DQMH 4.1. This version contains the new menu structure and the new commands.


Thanks a lot, Claude! Greetings from Würzburg


An opportunity to learn from experienced developers / entrepreneurs (Fab, Steve and Brian amongst them):
DSH Pragmatic Software Development Workshops
Automate the analyzing, testing, documenting, building, packaging and publishing of your projects via CI/CD:
Release Automation Tools for LabVIEW

0 Kudos
Message 20 of 35
(1,236 Views)