Delacor Toolkits Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

API Tester VI gets broken when using LVLIBP from TestStand

Solved!
Go to solution

Hey everyone,

 

I have a rather strange issue (at least to me)...

I build a DQMH module that does some manipulation of NSVs, which are hosted on a myRIO, which in itself is kind of a HIL system.

 

Everything runs fine in LabVIEW dev environment. Building LVLIBP runs smoothly as well (mass-compile and "saving all" executes flawlessly)..

 

But... When I choose the API Tester VI from the created LVLIBP in TestStand (2020), I get the following error:

ngblume_0-1610753518668.png

And it only happens with this VI.. All other VI show up working in TestStand..

 

None of the suggestions help with ithe issue..
I also tried most basic stuff like disconnecting type defs, etc.

*EDIT: The API Tester VI is part of the LIB just for building the LVLIBP and is moved back out as per Fabiola's recommendations..

 

Run out of ideas.. any pointers here??

 

Thanks!

 

Cheers

Niels Göran

0 Kudos
Message 1 of 4
(126 Views)
Solution
Accepted by FabiolaDelaCueva

Apparently, I didn't properly tried the "Disconnect type defintions"..

Set check mark for real, issue fixed ..

Whatever happened there..

Message 2 of 4
(119 Views)

@ngblume wrote:

Apparently, I didn't properly tried the "Disconnect type defintions"..

Set check mark for real, issue fixed ..

Whatever happened there..


Glad you were able to fix it, yes, building PPLs is an art... or magic... and thanks for coming back to let us know what worked for you.

 

Regards,

Fab

 

I'm Organizing the GLA Summit!


For an opportunity to learn from experienced developers / entrepeneurs (Steve, Joerg, and Brian amongst them):
Check out DSH Pragmatic Software Development Workshop!

DQMH Lead Architect * DQMH Trusted Advisor * Certified LabVIEW Architect * Certified LabVIEW Embedded Developer * Certified Professional Instructor * LabVIEW Champion * Code Janitor

Have you been nice to future you?
0 Kudos
Message 3 of 4
(50 Views)

Hey hey,

 

by the way, any thoughts on strucutres in LVLIBPs (probably also magic required):

https://forums.ni.com/t5/Delacor-Toolkits-Discussions/Preserve-virtual-folder-structure-in-LVLIBP-of...

 

Thanks!

 

Niels

0 Kudos
Message 4 of 4
(42 Views)