DQMH Consortium Toolkits Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1 occurred at property Node (arg 2)

Solved!
Go to solution

I all,

 

I've been using the DMQH toolkit for a project for about 3 months now, i'm feeling very confortable with this toolkit.


From today I can no longer create new events for one of my modules called Server MAIN.lvlib.


The error I get when i try to create a new event into Server MAIN.lvlib is the following:

esodar1981_0-1663599719931.png

 

In addition, this module is included into a large project, with others modules created using DMQH toolkit.

Creating new DMQH event in this project do not cause the error to appear, but the module Server MAIN.lvlib is not present into the top/down module list.

 

I'm using version control, tried also to revert to older version.. but with no sucess.

 

Is there a way to solve this?

What could cause this error?

 

Thanks for your help

0 Kudos
Message 1 of 9
(345 Views)

If you run the Validate DQMH Module tool on the project, does the problematic module show up in the modules list? If so, are any validation failures returned when you try to validate that module?

0 Kudos
Message 2 of 9
(334 Views)

Unfortunately not, the module did not appear even in the validation module list

 

EDIT: this is what i see from project when trying to create event or validate module

esodar1981_0-1663603179074.png

0 Kudos
Message 3 of 9
(330 Views)

Here are the things the DQMH scripting tools look for in order to see if something is a DQMH module:

Public API > Requests virtual folder

Public API > Arguments > Request virtual folder

Public API > Arguments > Broadcast virtual folder

Broadcasts virtual folder

Obtain Broadcast Events.vi VI file

Destroy Broadcast Events.vi VI file

Obtain Request Events.vi VI file

Destroy Request Events.vi VI file

Request Events--cluster.ctl CTL file

Broadcast Events--cluster.ctl CTL file

Module Timeout--constant.vi VI file

Module Name--constant.vi VI file

Status Updated.vi VI file

Module Not Running--error.vi VI file

 

If any of those items are missing within the Module .lvlib, the scripting tools will not recognize it as a DQMH Module. I suggest looking through your module to see if any of those items are missing. Perhaps you accidentally renamed one of the virtual folders or VIs?

Message 4 of 9
(307 Views)

Thanks for your help,

all the reported modules and virtual folders seems present into the Server MAIN.lvlib

esodar1981_0-1663605578739.png

Am i missing something?

I cannot guarantee i've not accidentally renamed any of the virtual folders.. all seems properly named into the project

0 Kudos
Message 5 of 9
(293 Views)
Solution
Accepted by topic author esodar1981

You renamed the top-level 'Broadcasts' folder to 'Broadcast'. Try fixing that and seeing if it works.

Message 6 of 9
(285 Views)

..the eye of the eagle.. it worked!

 

Many thanks

0 Kudos
Message 7 of 9
(281 Views)

We've had it quite a few times where someone would rename a resource within a DQMH module and break scripting.

 

So the take-away lesson here is: Try to stay away from renaming DQMH resources, and double-check you didn't rename anything vital if scripting breaks.


DSH Pragmatic Software Development Workshops (Fab, Steve, Brian and me)
Release Automation Tools for LabVIEW (CI/CD integration with LabVIEW)
DQMH® (The Future of Team-Based LabVIEW Development)

Message 8 of 9
(260 Views)

Lesson learned, thank you!

0 Kudos
Message 9 of 9
(257 Views)