DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

diadem 11 installation error: Object required: navigator,display.currdataProvider

Solved!
Go to solution
Highlighted

On installing Diadem 11.0 I get an error message popup when I open the program the first (and subsequent) times and the navigator tab view is corrupted:

 

Object required: 'navigator,display.currdataProvider'

 

Also when the program is first opened after installing a message pops up warning about errors during installation and to check the logfile but I can't find it.

 

I am using windows vista 64 bit.

 

Thanks, Steve.

0 Kudos
Message 1 of 23
(4,383 Views)

I would begin by reinstalling DIAdem. You will need to remove it entirely using MSIBlast first.

Let me know if this helps.

 

Thanks,


Philip
Applications Engineer
National Instruments
UK Branch

===If this fixes your problem, mark as solution!===
0 Kudos
Message 2 of 23
(4,338 Views)

Thanks for your reply,

 

I had already unisnstalled Diadem. When I ran MSIBlast Diadem was not on the list of installed MSI packages.

 

I have also tried installing Diadem 11.1. This failed with the same error but gave a bit more information and said part of the opperating system was not as originally installed and that this may be caused by 'hot-fixes' or other programs etc.

 

The install on my machine is relatively new and clean as it is my office PC and I have had no problems with anything else. I have also tried installing both versions of Diadem from ISO images created on another machine rather than disk incase it was some sort of reading error.

 

Regards, Steve.

0 Kudos
Message 3 of 23
(4,329 Views)

Hi Steve,

 

First note that the 4 images in your first post did not make it, so we have not seen them.  If you think they are important, please re-post them as attachments.  Second, at the end of the DIAdem 11.x installation, did you get a pop-up dialog telling you that DIAdem was completing the installation?  This is when various DIAdem components are registered, and if you were to try to launch DIAdem manually before this process finishes, then you might end up in a state such as you describe.  When I consulted with R&D on your issue, they wondered if perhaps the "completing installation" dialog was taking too long to pop up on your VISTA computer, such that you didn't know to just hang out and wait for the component registration process to end.  R&D also mentioned that when installing on VISTA a reboot is required before the first manual launch of DIAdem.  They also mentioned that VISTA will pop up many more dialogs during the installation, ALL of which you need to answer with "not blocking".  Finally, R&D said that since DIAdem 11.x is a 32bit application, you need to install to folders that start with:

 

C:\Program Files (x86)\National Instruments\

 

Brad Turpin
DIAdem Product Support Engineer
National Instruments

0 Kudos
Message 4 of 23
(4,314 Views)

Hi Brad,

 

Finally had another go at installing Diadem. The installation appears to be fine, get the finalising installation message which closes itself. Then I manually rebooted the PC and fire up Diadem. Unfortunatally I was greeted by the familiar error messages.

 

I have attached screen shots of these and also the corrupt navigator page. All other pages eg view, analysis, report etc are fine.

 

Regards,

Steve.

0 Kudos
Message 5 of 23
(4,275 Views)
I've also attached the more descriptive error from when I tried Diadem 11.1 here......
0 Kudos
Message 6 of 23
(4,274 Views)
Solution
Accepted by topic author St3ve
08-27-2015 04:09 PM

Hi Steve,

 

Thanks for the reposted screenshots-- they gave R&D a better understanding of what is going on.  They now believe that the DIAdem is installing just fine and that the problem is an incompatability at launch time between DIAdem and a Windows hotfix.  We normally see this issue when a DIAdem installation has been working for a while and then suddenly fails to launch after the customer installed a Windows update or a new version/update of AutoCad or SQL Server, etc.  This Windows hotfix is often bundled with other software so that you don't even know you're getting it.  What it does is specifically tell Windows to ignore the Windows DLL version (stored in the Windows Registry) that the DIAdem installer told the OS to use, and instead use a new version of the Windows DLL that doesn't work with DIAdem.

 

I have posted an executable to our outgoing ftp site which has been very successful in addressing this issue and enabling DIAdem to launch again.  Note that this "St3ve.exe" file will only be up there for a few days.

 

ftp.ni.com/outgoing/St3ve.exe

 

Please let us know either way what happens,

Brad Turpin
DIAdem Product Support Engineer
National Instruments

Message 7 of 23
(4,212 Views)
Many thanks for your help, ran the installer and diadem now runs perfectly.
0 Kudos
Message 8 of 23
(4,200 Views)

Can you please repost the st3ve.exe?  Looks like the ftp was cleaned up in the last few years.

 

I've got a similar situation with Diadem 2010

0 Kudos
Message 9 of 23
(2,519 Views)

Hi J,

 

I just reposted St3ve.exe to the outgoing ftp site.  Files only stay up there for a few days before being automatically cleaned off.

 

Hope that helps,

Brad Turpin

DIAdem Product Support Engineer

National Instruments

0 Kudos
Message 10 of 23
(2,500 Views)