DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 

XMS - time of begin and end return strange number

Hi, im calling the XMS function on channel

The first option "Calculation within one peak" returns times in ms, as the input channel is waveform with waveform unit setted to ms.

All good.

 

But when i change it to "Calculation including all peaks", it return 1000x bigger number. Its normal behaviour?

 

check the screens 🙂

 

XMS0.png

 

XMS1.png

 

 

 

0 Kudos
Message 1 of 6
(201 Views)

Hey Lukas,

 

What version of DIAdem are you using?  Do you see this effect with all data files you've tried or just certain ones?

 

Brad Turpin

DIAdem Product Support Engineer

National Instruments

0 Kudos
Message 2 of 6
(154 Views)

Hi, 2017 64bit. And im not alolen, my colleagues have the same behaviour, when i noticed them, they told me they know about it and they are used to it instead of report it to me 🙂

0 Kudos
Message 3 of 6
(141 Views)

Hey Lukas,

 

I mentioned this to R&D, and they have asked if you would submit a data set that shows this effect, either to this post or to brad.turpin@ni.com.

 

Then they'll investigate,

Brad Turpin

DIAdem Product Support Engineer

National Instruments

0 Kudos
Message 4 of 6
(118 Views)

Hi, 

Try running this command

Call ChnXMSCalc("", "[1]/11HEAD0000WSACRP" , 3, 0, "in multiple peaks", false)

 The result if 34.8474113155008 which i recognised as true result.

 

Then try convert the waveform x-unit to "ms".

after runnig the same command, i got the result: 39.2131886153666 which i think is false. imho it should return the same result, because the input parameter is specified like this "

Specifies the time X in milliseconds

". (((it should be written smtin like this "if you have channel in ms, specifies the X in ms*1000, other case just ms*1" )))" i think the program should deal with it, or have it written in help, that the input channel must meet the specs to have the waveform in specified units. but now its not specified and i the different results got me confused, cause i dont know what to say to my colleagues who use my program that we have different results. 

i tested it now in Diadem 2019 but there is the same behaviour..

 

We will soon start to use Diadem 2019 so it could be good to have it fixed. Thanks for info how it goes.

0 Kudos
Message 5 of 6
(44 Views)

i added attachement, tdm file in zip archive, but i dont see it, tell me if you see it and download it or i will reupload it

0 Kudos
Message 6 of 6
(43 Views)