DIAdem

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Problem with calling a VI using DIADEM script : Interpolation

Solved!
Go to solution

Hello community.
I wanted to use my subVI attached using DIAdem script. So, I referred this material. I know DIAdem already have the function of Interpolation, But I just tried to improve performance of my project, So I chose interpolation from LabVIEW.

VI is so simple. But, In this process, I got error like this.
111.PNG
(※ 'Output', 'VI' are variable what i defined )

Call VI.Run(true)

Answer = VI.GetControlValue("Output")
"

Before I got 'output' from VI, I think I did execution 'Call VI.Run(true)'. Anyone knows how can I solve this problem?

Thank you in advance.

 





0 Kudos
Message 1 of 2
(278 Views)
Solution
Accepted by topic author chisbae
01-09-2019 11:29 PM

Hello again
I already resolved this problem. But, I am not sure what problem was still. 

After I erased command 'SetControlValue' for 'X,Y,Z' input control of 'Interpolate 2D(1d,xi,yi).vi', the problem solved.
I attached the solution file for community reference. If someone get in trouble with this kinds of issue, just let me know.

Thanks.

0 Kudos
Message 2 of 2
(220 Views)